blob: bf26a8c078548600e2f72ce78f330582121ab838 [file] [log] [blame]
Brandon Kimcb27e732021-03-08 21:44:23 -08001SUMMARY = "ACPI Power/Sleep state daemon to allow host state events"
2DESCRIPTION = "ACPI Power/Sleep state daemon to allow host state events"
3HOMEPAGE = "http://github.com/openbmc/google-misc"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://../LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
9
10SRC_URI += "git://github.com/openbmc/google-misc"
11SRCREV = "15fe169d1fbdd510bb9cfc9bb725baf0613350ff"
12S = "${WORKDIR}/git/acpi-power-state-daemon"
13
14inherit meson
15inherit pkgconfig
16inherit systemd
17
18DEPENDS += " \
19 phosphor-dbus-interfaces \
20 sdbusplus \
21 systemd \
22 "
23
24SYSTEMD_SERVICE_${PN} = " \
25 acpi-power-state.service \
26 host-s0-state.target \
27 host-s5-state.target \
28 "