Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Simple DirectMedia Layer image library v2" |
| 2 | SECTION = "libs" |
| 3 | |
| 4 | LICENSE = "Zlib" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=a855a9eb5507fc556e672080c4b428ca" |
| 6 | |
| 7 | DEPENDS = "tiff zlib libpng jpeg virtual/libsdl2 libwebp" |
| 8 | |
| 9 | SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL2_image-${PV}.tar.gz" |
| 10 | SRC_URI[md5sum] = "c6baf6dfa80fa8a66853661a36a6034e" |
| 11 | SRC_URI[sha256sum] = "3510c25da735ffcd8ce3b65073150ff4f7f9493b866e85b83738083b556d2368" |
| 12 | |
| 13 | S = "${WORKDIR}/SDL2_image-${PV}" |
| 14 | |
| 15 | inherit autotools pkgconfig |
| 16 | |
| 17 | # Disable the run-time loading of the libs and bring back the soname dependencies. |
| 18 | EXTRA_OECONF += "--disable-jpg-shared --disable-png-shared -disable-tif-shared" |
| 19 | |
| 20 | do_configure_prepend() { |
| 21 | # make autoreconf happy |
| 22 | touch ${S}/NEWS ${S}/README ${S}/AUTHORS ${S}/ChangeLog |
| 23 | # Removing these files fixes a libtool version mismatch. |
| 24 | rm -f ${S}/acinclude/libtool.m4 |
| 25 | rm -f ${S}/acinclude/sdl2.m4 |
| 26 | rm -f ${S}/acinclude/pkg.m4 |
| 27 | rm -f ${S}/acinclude/lt~obsolete.m4 |
| 28 | rm -f ${S}/acinclude/ltoptions.m4 |
| 29 | rm -f ${S}/acinclude/ltsugar.m4 |
| 30 | rm -f ${S}/acinclude/ltversion.m4 |
| 31 | } |