blob: bdc0c770ad247bcecd1602e24c9bc1c30d15197a [file] [log] [blame]
Deepak Kodihalli14c47d22017-03-17 03:51:13 -05001SUMMARY = "Open POWER DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the openpower YAML"
3PR = "r1"
Patrick Venture92feebc2018-10-02 19:51:03 -07004PV = "1.0+git${SRCPV}"
Patrick Venturef9afb7a2018-11-03 09:10:39 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Deepak Kodihalli14c47d22017-03-17 03:51:13 -05007
8S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
Deepak Kodihalli14c47d22017-03-17 03:51:13 -050011inherit pythonnative
Marri Devender Rao8dd77982017-05-29 01:33:26 -050012inherit phosphor-dbus-yaml
Deepak Kodihalli14c47d22017-03-17 03:51:13 -050013
14DEPENDS += "autoconf-archive-native"
15DEPENDS += "sdbus++-native"
16
Deepak Kodihalli14c47d22017-03-17 03:51:13 -050017SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces"
Andrew Geisslerd84cbdf2019-02-15 20:21:00 +000018SRCREV = "2f7e6758be4bfb4c02027b82e21b50861ffd90af"
Deepak Kodihalli14c47d22017-03-17 03:51:13 -050019
20DEPENDS_remove_class-native = "sdbus++-native"
21DEPENDS_remove_class-nativesdk = "sdbus++-native"
22
23PACKAGECONFIG ??= "libopenpower_dbus"
24PACKAGECONFIG[libopenpower_dbus] = " \
25 --enable-libopenpower_dbus, \
26 --disable-libopenpower_dbus, \
27 systemd sdbusplus, \
28 libsystemd sdbusplus \
29 "
30
31PACKAGECONFIG_remove_class-native = "libopenpower_dbus"
32PACKAGECONFIG_remove_class-nativesdk = "libopenpower_dbus"
33
34BBCLASSEXTEND += "native nativesdk"