blob: 805b3a7c63da0ec135a0b33f0b21679d219f82b8 [file] [log] [blame]
Brad Bishop0a544b52017-01-28 12:51:42 -05001SUMMARY = "Generate inventory map for phosphor-ipmi-fru from an MRW."
2PR = "r1"
Patrick Venture8f93a292018-10-26 09:58:28 -07003PV = "1.0+git${SRCPV}"
Brad Bishop0a544b52017-01-28 12:51:42 -05004
5inherit native
6inherit phosphor-ipmi-fru
Matt Spinler0a8ea632017-12-14 13:31:55 -06007inherit mrw-xml
Brad Bishop0a544b52017-01-28 12:51:42 -05008
9require phosphor-ipmi-fru.inc
10
11DEPENDS += "mrw-native mrw-perl-tools-native"
12
13# TODO: remove this dependency after the MRW script
14# has been updated to not require the hostfw metadata.
15DEPENDS += "virtual/phosphor-ipmi-fru-hostfw-config"
16
17PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
18
19S = "${WORKDIR}/git"
20do_install() {
21
22 DEST=${D}${config_datadir}
23 install -d ${DEST}
24
25 ${bindir}/perl-native/perl \
26 ${bindir}/gen_ipmi_fru.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060027 -i ${mrw_datadir}/${MRW_XML} \
Brad Bishop0a544b52017-01-28 12:51:42 -050028 -m ${hostfw_datadir}/config.yaml \
29 -o ${DEST}/config.yaml
30}