blob: 4e58cf44691acc670b53f054d5cc18d070ecc8be [file] [log] [blame]
Ratan Gupta3aa591f2017-03-06 17:05:11 +05301SUMMARY = "Sensor config for phosphor-host-ipmi"
2PR = "r1"
Brad Bishop75f03872018-11-03 09:41:57 -07003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Ratan Gupta3aa591f2017-03-06 17:05:11 +05305
6inherit native
7inherit phosphor-ipmi-host
Ratan Gupta3aa591f2017-03-06 17:05:11 +05308
9PROVIDES += "virtual/phosphor-ipmi-sensor-inventory"
10
11SRC_URI += "file://config.yaml"
12
13S = "${WORKDIR}"
14
15do_install() {
16 # This recipe is supposed to create an output yaml file with
17 # sensor data extracted from the mrw.
18 # provides a sample output file.
19
Ratan Gupta65e6e472017-03-17 19:37:28 +053020 DEST=${D}${sensor_datadir}
Ratan Gupta3aa591f2017-03-06 17:05:11 +053021 install -d ${DEST}
22 install config.yaml ${DEST}/sensor.yaml
23}