Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "An HTTP library implementation in C" |
| 2 | HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | SECTION = "x11/gnome/libs" |
| 5 | LICENSE = "LGPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 7 | |
| 8 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native libpsl" |
| 9 | |
| 10 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
| 11 | |
| 12 | SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz \ |
| 13 | file://0001-Do-not-enforce-no-introspection-when-cross-building.patch \ |
| 14 | " |
| 15 | SRC_URI[md5sum] = "cac755dc6c6acd6e0c70007f547548f5" |
| 16 | SRC_URI[sha256sum] = "75ddc194a5b1d6f25033bb9d355f04bfe5c03e0e1c71ed0774104457b3a786c6" |
| 17 | |
| 18 | S = "${WORKDIR}/libsoup-${PV}" |
| 19 | |
| 20 | inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc |
| 21 | |
| 22 | # libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default. |
| 23 | PACKAGECONFIG ??= "" |
| 24 | PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false" |
| 25 | PACKAGECONFIG[gssapi] = "-Dgssapi=true,-Dgssapi=false,krb5" |
| 26 | |
| 27 | EXTRA_OEMESON_append = " -Dvapi=false" |
| 28 | |
| 29 | GTKDOC_ENABLE_FLAG = "-Ddoc=true" |
| 30 | GTKDOC_DISABLE_FLAG = "-Ddoc=false" |
| 31 | |
| 32 | GI_ENABLE_FLAG = "-Dintrospection=true" |
| 33 | GI_DISABLE_FLAG = "-Dintrospection=false" |
| 34 | |
| 35 | EXTRA_OEMESON_append_class-nativesdk = " ${GI_DISABLE_FLAG}" |
| 36 | |
| 37 | EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '${GI_ENABLE_FLAG}', \ |
| 38 | '${GI_DISABLE_FLAG}', d)} " |
| 39 | |
| 40 | EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_ENABLE_FLAG}', \ |
| 41 | '${GTKDOC_DISABLE_FLAG}', d)} " |
| 42 | |
| 43 | |
| 44 | # When built without gnome support, libsoup-2.4 will contain only one shared lib |
| 45 | # and will therefore become subject to renaming by debian.bbclass. Prevent |
| 46 | # renaming in order to keep the package name consistent regardless of whether |
| 47 | # gnome support is enabled or disabled. |
| 48 | DEBIAN_NOAUTONAME_${PN} = "1" |
| 49 | |
| 50 | # glib-networking is needed for SSL, proxies, etc. |
| 51 | RRECOMMENDS_${PN} = "glib-networking" |