blob: dc1279d314767fc6fdd62d9879822c70779384b9 [file] [log] [blame]
Jeremy Kerr708f0cc2019-12-20 12:02:36 +08001SUMMARY = "MCTP stack"
2DESCRIPTION = "MCTP library implementing the MCTP base specification"
Jeremy Kerr708f0cc2019-12-20 12:02:36 +08003HOMEPAGE = "https://github.com/openbmc/libmctp"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=0d30807bb7a4f16d36e96b78f9ed8fae"
Jeremy Kerr708f0cc2019-12-20 12:02:36 +08006DEPENDS += "autoconf-archive-native \
7 systemd \
George Liu948c7b42021-06-24 11:13:15 +08008 "
Andrew Geisslercbf87dd2023-10-04 19:50:09 -05009SRCREV = "400766f94322a00981b012e714734cab0ed52e68"
Ed Tanous9936f862022-09-19 09:13:20 -070010PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} pcap"
11PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, \
12 --without-systemdsystemunitdir,systemd"
Ed Tanous9936f862022-09-19 09:13:20 -070013PACKAGECONFIG[pcap] = "--enable-capture,--disable-capture,libpcap,"
14PV = "1.0+git${SRCPV}"
15PR = "r1"
16
17SRC_URI = "git://github.com/openbmc/libmctp;branch=master;protocol=https \
18 file://default"
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080019
Patrick Williams12fc9392021-08-06 09:16:53 -050020SYSTEMD_SERVICE:${PN} = "mctp-demux.service \
George Liu948c7b42021-06-24 11:13:15 +080021 mctp-demux.socket \
22 "
Ed Tanous9936f862022-09-19 09:13:20 -070023S = "${WORKDIR}/git"
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080024
Ed Tanous9936f862022-09-19 09:13:20 -070025inherit systemd
26inherit autotools pkgconfig
Andrew Jefferyd957f032021-05-12 22:31:34 +093027
Patrick Williams12fc9392021-08-06 09:16:53 -050028do_install:append() {
Ed Tanous9936f862022-09-19 09:13:20 -070029 install -d ${D}${sysconfdir}/default
30 install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/mctp
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080031}
32
Ed Tanous9936f862022-09-19 09:13:20 -070033CONFFILES:${PN} = "${sysconfdir}/default/mctp"