blob: 70807de2a1db72e83be9a396ee765494513505b1 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \
2for the development of SOAP Web Services and clients."
3SECTION = "devel"
4LICENSE = "GPL-2.0-with-OpenSSL-exception"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4f40a941379143186f9602242c3fb729 \
6 file://GPLv2_license.txt;md5=a33672dbe491b6517750a0389063508b"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}2/${BPN}_${PV}.zip \
9 "
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050010SRC_URI[md5sum] = "ce91e46d3abc1d720566b13298fbc367"
11SRC_URI[sha256sum] = "aa20c535cf08f1576bebad97cc6159ca57c68bc43acfc9a296e4e9faf041097e"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13inherit autotools
14
15BBCLASSEXTEND = "native"
16
17S = "${WORKDIR}/${BPN}-2.8"
18
19PARALLEL_MAKE = ""
20
21EXTRA_OEMAKE_class-target = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2"
22
23DEPENDS = "openssl zlib flex bison bison-native"
24DEPENDS_append_class-target = " gsoap-native"
25
26do_install_append() {
27 install -d ${D}${libdir}
28 for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
29 do
30 oe_libinstall -C gsoap $lib ${D}${libdir}
31 done
32}
33
34do_install_class-native() {
35 oe_runmake DESTDIR=${D} BINDIR=${D}${bindir} install
36}
37
38FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2"
39FILES_${PN} += "${datadir}"
40FILES_${PN}-staticdev = "${libdir}"
41FILES_${PN}-dev = "${includedir}"
42RRECOMMENDS_${PN}-dev = "${PN}-staticdev"