blob: dc696b138681bbaa3bca0450678f5924f7c9fe35 [file] [log] [blame]
Marri Devender Rao53c55032017-07-26 02:11:32 -05001SUMMARY = "BMC accesible FRU inventory map for phosphor-ipmi-host"
2PR = "r1"
Brad Bishop75f03872018-11-03 09:41:57 -07003LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Marri Devender Rao53c55032017-07-26 02:11:32 -05005
6inherit native
Marri Devender Rao53c55032017-07-26 02:11:32 -05007inherit phosphor-ipmi-host
8
9SRC_URI += "file://bmc-fru-config.yaml"
10
11S = "${WORKDIR}"
12
13PROVIDES += "virtual/phosphor-ipmi-fru-read-bmc-inventory"
14
15do_install_append() {
16 DEST=${D}${config_datadir}
17 install -d ${DEST}
18 install bmc-fru-config.yaml ${DEST}/bmc-fru-config.yaml
19}
20