blob: d8bb04aa1e3407a27df7a690bb5f5d3e6f2dffec [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001require recipes-core/images/core-image-minimal.bb
2
Patrick Williamsc0f7c042017-02-23 20:41:17 -06003# Skip processing of this recipe if linux-yocto-rt is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers.
6python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
9}
10
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011DESCRIPTION = "A small image just capable of allowing a device to boot plus a \
12real-time test suite and tools appropriate for real-time use."
13DEPENDS = "linux-yocto-rt"
14
15IMAGE_INSTALL += "rt-tests hwlatdetect"
16
17LICENSE = "MIT"