Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "in-depth comparison of files, archives, and directories" |
| 2 | DESCRIPTION = "Tries to get to the bottom of what makes files or directories \ |
| 3 | different. It will recursively unpack archives of many kinds and transform \ |
| 4 | various binary formats into more human-readable form to compare them. \ |
| 5 | It can compare two tarballs, ISO images, or PDF just as easily." |
| 6 | HOMEPAGE = "https://diffoscope.org/" |
| 7 | BUGTRACKER = "https://salsa.debian.org/reproducible-builds/diffoscope/-/issues" |
| 8 | LICENSE = "GPL-3.0-or-later" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 10 | |
| 11 | PYPI_PACKAGE = "diffoscope" |
| 12 | |
| 13 | inherit pypi setuptools3 |
| 14 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "ca3d826b691f4998d6de28a016b3555d56a7283b97ad92944ce643ea6e7eb614" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 16 | |
| 17 | RDEPENDS:${PN} += "\ |
| 18 | binutils \ |
| 19 | python3-curses \ |
| 20 | python3-difflib \ |
| 21 | python3-fcntl \ |
| 22 | python3-json \ |
| 23 | python3-libarchive-c \ |
| 24 | python3-magic \ |
| 25 | python3-multiprocessing \ |
| 26 | python3-pprint \ |
| 27 | python3-rpm \ |
| 28 | squashfs-tools \ |
| 29 | vim \ |
| 30 | " |
| 31 | |
| 32 | # Dependencies don't build for musl |
| 33 | COMPATIBLE_HOST:libc-musl = 'null' |
| 34 | |
| 35 | do_install:append:class-native() { |
| 36 | create_wrapper ${D}${bindir}/diffoscope \ |
| 37 | MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \ |
| 38 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ |
| 39 | LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \ |
| 40 | RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} |
| 41 | } |
| 42 | |
| 43 | BBCLASSEXTEND = "native" |