Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Liberation(tm) Fonts" |
| 2 | DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \ |
| 3 | created by Ascender(c) which aims at metric compatibility with \ |
| 4 | Arial, Times New Roman, Courier New." |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 5 | HOMEPAGE = "https://github.com/liberationfonts/liberation-fonts" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 6 | BUGTRACKER = "https://bugzilla.redhat.com/" |
| 7 | |
| 8 | SECTION = "x11/fonts" |
| 9 | LICENSE = "OFL-1.1" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f96db970a9a46c5369142b99f530366b" |
| 11 | PE = "1" |
| 12 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 13 | SRC_URI = "https://github.com/liberationfonts/liberation-fonts/files/6418984/liberation-fonts-ttf-${PV}.tar.gz \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 14 | file://30-liberation-aliases.conf" |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "26f85412dd0aa9d061504a1cc8aaf0aa12a70710e8d47d8b65a1251757c1a5ef" |
| 16 | UPSTREAM_CHECK_URI = "https://github.com/liberationfonts/liberation-fonts/releases" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | |
| 18 | S = "${WORKDIR}/liberation-fonts-ttf-${PV}" |
| 19 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 20 | inherit allarch fontcache |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 21 | |
| 22 | do_install () { |
| 23 | install -d ${D}${datadir}/fonts/ttf/ |
| 24 | for i in *.ttf; do |
| 25 | install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i} |
| 26 | done |
| 27 | |
| 28 | install -d ${D}${sysconfdir}/fonts/conf.d/ |
| 29 | install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/ |
| 30 | |
| 31 | install -d ${D}${prefix}/share/doc/${BPN}/ |
| 32 | install -m 0644 LICENSE ${D}${datadir}/doc/${BPN}/ |
| 33 | } |
| 34 | |
| 35 | PACKAGES = "${PN}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | FILES:${PN} += "${sysconfdir} ${datadir}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 37 | |
| 38 | BBCLASSEXTEND = "native nativesdk" |