Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Generic XKB keymap library" |
| 2 | DESCRIPTION = "libxkbcommon is a keymap compiler and support library which \ |
| 3 | processes a reduced subset of keymaps as defined by the XKB specification." |
| 4 | HOMEPAGE = "http://www.xkbcommon.org" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e525ed9809e1f8a07cf4bce8b09e8b87" |
| 6 | LICENSE = "MIT & MIT-style" |
| 7 | |
| 8 | DEPENDS = "util-macros flex-native bison-native" |
| 9 | |
| 10 | SRC_URI = "http://xkbcommon.org/download/${BPN}-${PV}.tar.xz" |
| 11 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "7b09e098ea69bc3054f0c57a9a25fda571c4df22398811606e32b5fffeb75e7b" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
| 14 | UPSTREAM_CHECK_URI = "http://xkbcommon.org/" |
| 15 | |
| 16 | inherit meson pkgconfig |
| 17 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 18 | EXTRA_OEMESON = "-Denable-docs=false -Denable-xkbregistry=false" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | |
| 20 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)}" |
| 21 | PACKAGECONFIG[x11] = "-Denable-x11=true,-Denable-x11=false,libxcb xkeyboard-config," |
| 22 | PACKAGECONFIG[wayland] = "-Denable-wayland=true,-Denable-wayland=false,wayland-native wayland wayland-protocols," |
| 23 | |
| 24 | # Fix a following runtime error: |
| 25 | # xkbcommon: ERROR: couldn't find a Compose file for locale "C" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | RDEPENDS:${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', 'libx11-compose-data', d)}" |