blob: 7fc87db2bdc0fe549d662ed869cb6650dbc5bfe9 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "fetch and change SCSI mode pages"
2DESCRIPTION = "The sdparm utility accesses and optionally modifies \
3SCSI devices' mode page and inquiry data."
4HOMEPAGE = "http://sg.danny.cz/sg/sdparm.html"
5SECTION = "console/utils"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=ecab6c36b7ba82c675581dd0afde36f7 \
8 file://lib/BSD_LICENSE;md5=12cde17a04c30dece2752f36b7192c64"
9DEPENDS="sg3-utils"
10SRC_URI = "http://sg.danny.cz/sg/p/${BPN}-${PV}.tgz \
11 file://make-sysroot-work.patch \
12 "
13MIRRORS += "http://sg.danny.cz/sg/p https://fossies.org/linux/misc"
14
15UPSTREAM_CHECK_REGEX = "sdparm-(?P<pver>\d+(\.\d+)+)\.tgz"
16
17PACKAGES =+ "${PN}-scripts"
18RDEPENDS_${PN}-scripts += "bash ${PN}"
19
20SRC_URI[md5sum] = "cd998d1c12a4ec11652d0af580f06b4d"
21SRC_URI[sha256sum] = "432fdbfe90f0c51640291faf7602489b0ae56dfb96d0c02ed02308792adc7fb0"
22
23inherit autotools
24
25# Put the bash scripts to ${PN}-scripts
26FILES_${PN}-scripts = "${bindir}/sas_disk_blink ${bindir}/scsi_ch_swp"