blob: 9e933f5c4b5266ee3381dab66dc6f3e9fef56a97 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "matplotlib: plotting with Python"
2DESCRIPTION = "\
3Matplotlib is a Python 2D plotting library which produces \
4publication-quality figures in a variety of hardcopy formats \
5and interactive environments across platforms."
6HOMEPAGE = "https://github.com/matplotlib/matplotlib"
7SECTION = "devel/python"
8LICENSE = "PSF"
9LIC_FILES_CHKSUM = "\
Andrew Geisslere34f8962021-04-15 15:53:51 -050010 file://setup.py;beginline=282;endline=282;md5=20e7ab4d2b2b1395a0e4ab800181eb96 \
Andrew Geissler82c905d2020-04-13 13:39:40 -050011 file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
12"
13DEPENDS = "\
14 freetype \
15 libpng \
16 python3-numpy-native \
17 python3-dateutil-native \
18 python3-pytz-native \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050019 python3-certifi-native \
Andrew Geissler82c905d2020-04-13 13:39:40 -050020"
21
Andrew Geisslere34f8962021-04-15 15:53:51 -050022SRC_URI[sha256sum] = "84d4c4f650f356678a5d658a43ca21a41fca13f9b8b00169c0b76e6a6a948908"
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
24inherit pypi setuptools3 pkgconfig
25
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050026# LTO with clang needs lld
Patrick Williams213cb262021-08-07 19:21:33 -050027LDFLAGS:append:toolchain-clang = " -fuse-ld=lld"
28LDFLAGS:remove:toolchain-clang:mips = "-fuse-ld=lld"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050029
Patrick Williams213cb262021-08-07 19:21:33 -050030RDEPENDS:${PN} = "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050031 freetype \
32 libpng \
33 python3-numpy \
34 python3-pyparsing \
35 python3-cycler \
36 python3-dateutil \
37 python3-kiwisolver \
38 python3-pytz \
39"
40
Patrick Williams213cb262021-08-07 19:21:33 -050041ENABLELTO:toolchain-clang:riscv64 = "echo enable_lto = False >> ${S}/setup.cfg"
42ENABLELTO:toolchain-clang:riscv32 = "echo enable_lto = False >> ${S}/setup.cfg"
43ENABLELTO:toolchain-clang:mips = "echo enable_lto = False >> ${S}/setup.cfg"
44do_compile:prepend() {
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050045 echo [libs] > ${S}/setup.cfg
46 echo system_freetype = true >> ${S}/setup.cfg
Andrew Geissler4b7c1152020-11-30 19:55:29 -060047 ${ENABLELTO}
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050048}
49
Andrew Geissler82c905d2020-04-13 13:39:40 -050050BBCLASSEXTEND = "native"