blob: 816b728dc02255baf84437b2c25e83c054ee9825 [file] [log] [blame]
Andrew Geisslerd159c7f2021-09-02 21:05:58 -05001SUMMARY = "PKCS#11 (Cryptoki) support for Python"
2DESCRIPTION = "A high level, “more Pythonic” interface to the PKCS#11 (Cryptoki) standard to support HSM and Smartcard devices in Python."
3HOMEPAGE = "https://pypi.org/project/python-pkcs11/"
4SECTION = "devel/python"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://README.rst;beginline=337;endline=358;md5=f68bda54505b4002e6ec86e08125ef79"
7
8SRC_URI[sha256sum] = "9737e0c24cabb8bc9d48bf8c57c3df2a70f8cdd96b70c50290803286f9e46bf7"
9
10PYPI_PACKAGE = "python-pkcs11"
11
12inherit pypi setuptools3
13
14BBCLASSEXTEND = "native"
15
16DEPENDS += " \
17 python3-cython-native \
18 python3-setuptools-scm-native \
19 python3 \
20"
21
22RDEPENDS:${PN} += " \
23 python3-asn1crypto \
24 python3-cached-property \
25"