blob: 4dc61cfb37455518710329011a45f441493712f4 [file] [log] [blame]
Patrick Williams213cb262021-08-07 19:21:33 -05001SUMMARY = "Resource Public Key Infrastructure (RPKI) daemon"
2HOMEPAGE = "https://www.nlnetlabs.nl/projects/rpki/krill/"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
5
6DEPENDS = "openssl"
7
8include krill.inc
9
10# SRC_URI += "crate://crates.io/krill/0.9.1"
11SRC_URI += "git://github.com/NLnetLabs/krill.git;protocol=https;nobranch=1;branch=main"
12SRCREV = "d6c03b6f0199b1d10d252750a19a92b84576eb30"
13
14SRC_URI += "file://panic_workaround.patch"
15
16S = "${WORKDIR}/git"
17CARGO_SRC_DIR = ""
18
19inherit pkgconfig useradd systemd cargo
20
21
22do_install:append () {
23 install -d ${D}${sysconfdir}
24 install -d ${D}${datadir}/krill
25
26 install -m 664 ${S}/defaults/krill.conf ${D}${sysconfdir}/.
27 install ${S}/defaults/* ${D}${datadir}/krill/.
28}
29
30KRILL_UID ?= "krill"
31KRILL_GID ?= "krill"
32
33USERADD_PACKAGES = "${PN}"
34GROUPADD_PARAM:${PN} = "--system ${KRILL_UID}"
35USERADD_PARAM:${PN} = "--system -g ${KRILL_GID} --home-dir \
36 /var/lib/krill/ --no-create-home \
37 --shell /sbin/nologin ${BPN}"
38
39FILES:${PN} += "{sysconfdir}/defaults ${datadir}"