blob: 490e81243486a71b4fbe479c502d568c91265ab6 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
2DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
3OS-independent reference implementation of the Advanced Configuration and \
4Power Interface Specification (ACPI). ACPICA code contains those portions of \
5ACPI meant to be directly integrated into the host OS as a kernel-resident \
6subsystem, and a small set of tools to assist in developing and debugging \
7ACPI tables."
8
9HOMEPAGE = "http://www.acpica.org/"
10SECTION = "console/tools"
11
12LICENSE = "Intel | BSD | GPLv2"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060013LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=c33ce358fdcd142684e41e336b7992e8"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17DEPENDS = "m4-native flex-native bison-native"
18
19SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050020SRC_URI[sha256sum] = "4a0c14d5148666612aa0555c5179eaa86230602394fd1bc3d16b506fcf49b5de"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050021
Andrew Geissler82c905d2020-04-13 13:39:40 -050022UPSTREAM_CHECK_URI = "https://acpica.org/downloads"
23
24S = "${WORKDIR}/acpica-unix-${PV}"
25
26inherit update-alternatives
27
28ALTERNATIVE_PRIORITY = "100"
Patrick Williams213cb262021-08-07 19:21:33 -050029ALTERNATIVE:${PN} = "acpixtract acpidump"
Andrew Geissler82c905d2020-04-13 13:39:40 -050030
31EXTRA_OEMAKE = "CC='${CC}' \
32 OPT_CFLAGS=-Wall \
33 DESTDIR=${D} \
34 PREFIX=${prefix} \
35 INSTALLDIR=${bindir} \
36 INSTALLFLAGS= \
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060037 YACC=bison \
38 YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \
Andrew Geissler82c905d2020-04-13 13:39:40 -050039 "
40
41do_install() {
42 oe_runmake install
43}
44
45# iasl*.bb is a subset of this recipe, so RREPLACE it
46PROVIDES = "iasl"
Patrick Williams213cb262021-08-07 19:21:33 -050047RPROVIDES:${PN} += "iasl"
48RREPLACES:${PN} += "iasl"
49RCONFLICTS:${PN} += "iasl"
Andrew Geissler82c905d2020-04-13 13:39:40 -050050
51BBCLASSEXTEND = "native"