blob: a6522967d4778861668cf2575187fb5cb3925b58 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001LICENSE = "GPLv3+"
2LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
3
4require diffutils.inc
5
6SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.xz \
7 file://run-ptest \
Brad Bishop79641f22019-09-10 07:20:22 -04008 file://0001-Skip-strip-trailing-cr-test-case.patch \
Andrew Geisslerd159c7f2021-09-02 21:05:58 -05009 "
Brad Bishop19323692019-04-05 15:28:33 -040010
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050011SRC_URI[sha256sum] = "a6bdd7d1b31266d11c4f4de6c1b748d4607ab0231af5188fc2533d0ae2438fec"
Brad Bishop19323692019-04-05 15:28:33 -040012
13EXTRA_OECONF += "ac_cv_path_PR_PROGRAM=${bindir}/pr --without-libsigsegv-prefix"
14
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050015# latest gnulib is no longer able to handle this - I dare not try to fix that maze of abstractions and generators
16CFLAGS:mingw32 = " -DSA_RESTART=0"
17
Brad Bishop19323692019-04-05 15:28:33 -040018# Fix "Argument list too long" error when len(TMPDIR) = 410
19acpaths = "-I ./m4"
20
21inherit ptest
22
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN}-ptest += "make perl"
Brad Bishop19323692019-04-05 15:28:33 -040024
25do_install_ptest() {
26 t=${D}${PTEST_PATH}
27 install -D ${S}/build-aux/test-driver $t/build-aux/test-driver
28 cp -r ${S}/tests $t/
29 install ${B}/tests/Makefile $t/tests/
30 sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
31 -e 's|${DEBUG_PREFIX_MAP}||g' \
32 -e 's:${HOSTTOOLS_DIR}/::g' \
33 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
34 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
35 -e 's|^Makefile:|_Makefile:|' \
36 -e 's|bash|sh|' \
37 -e 's|^top_srcdir = \(.*\)|top_srcdir = ..\/|' \
38 -e 's|^srcdir = \(.*\)|srcdir = .|' \
39 -e 's|"`$(built_programs)`"|diff|' \
40 -e 's|gawk|awk|g' \
41 -i $t/tests/Makefile
42}