blob: 20e2deffa5aad8cc34890ca57b35e3fc833f5ef2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15"
16
17DEPENDS = "attr libaio libcap acl openssl zip-native"
Patrick Williams213cb262021-08-07 19:21:33 -050018DEPENDS:append:libc-musl = " fts "
19EXTRA_OEMAKE:append:libc-musl = " LIBC=musl "
20EXTRA_OECONF:append:libc-musl = " LIBS=-lfts "
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22# since ltp contains x86-64 assembler which uses the frame-pointer register,
23# set -fomit-frame-pointer x86-64 to handle cases where optimisation
24# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
25# earlier in CFLAGS, etc.
Patrick Williams213cb262021-08-07 19:21:33 -050026CFLAGS:append:x86-64 = " -fomit-frame-pointer"
Andrew Geissler82c905d2020-04-13 13:39:40 -050027
Patrick Williams213cb262021-08-07 19:21:33 -050028CFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__"
29CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070030SRCREV = "0fb171f2beddaf64bd27597577c206c0f892b3cd"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060031
Andrew Geissler82c905d2020-04-13 13:39:40 -050032SRC_URI = "git://github.com/linux-test-project/ltp.git \
Andrew Geissler635e0e42020-08-21 15:58:33 -050033 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050034 file://0001-syscalls-ioctl_ns05.c-ioctl_ns06.c-Fix-too-small-buf.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050035 "
36
37S = "${WORKDIR}/git"
38
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050039inherit autotools-brokensep pkgconfig
Andrew Geissler82c905d2020-04-13 13:39:40 -050040
41TARGET_CC_ARCH += "${LDFLAGS}"
42
43export prefix = "/opt/${PN}"
44export exec_prefix = "/opt/${PN}"
45
46PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
47EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
Andrew Geissler635e0e42020-08-21 15:58:33 -050048EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
Andrew Geissler82c905d2020-04-13 13:39:40 -050049# ltp network/rpc test cases ftbfs when libtirpc is found
50EXTRA_OECONF += " --without-tirpc "
51
52do_install(){
53 install -d ${D}${prefix}/
Andrew Geisslerc926e172021-05-07 16:11:35 -050054 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install
Andrew Geissler82c905d2020-04-13 13:39:40 -050055
56 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
57 # as it lacks dependency on some perl moudle such as LWP::Simple
58 # And this script previously works as a tool for analyzing failures from LTP
59 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
60 # http://khack.osdl.org to retrieve ltp test results run on
61 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
62 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
63
64 # Copy POSIX test suite into ${D}${prefix}/testcases by manual
65 cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases
66
67 # Makefile were configured in the build system
68 find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \
69 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
70 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
Andrew Geisslerc926e172021-05-07 16:11:35 -050071 -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
72 -e 's@[^ ]*--sysroot=[^ "]*@@g'
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050073
74 # The controllers memcg_stree test seems to cause us hangs and takes 900s
75 # (maybe we expect more regular output?), anyhow, skip it
76 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
Andrew Geissler82c905d2020-04-13 13:39:40 -050077}
78
Patrick Williams213cb262021-08-07 19:21:33 -050079RDEPENDS:${PN} = "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050080 attr \
81 bash \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050082 bc \
83 coreutils \
Andrew Geissler82c905d2020-04-13 13:39:40 -050084 cpio \
85 cronie \
86 curl \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050087 e2fsprogs \
Andrew Geissler82c905d2020-04-13 13:39:40 -050088 e2fsprogs-mke2fs \
89 expect \
90 file \
91 gawk \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050092 gdb \
Andrew Geissler82c905d2020-04-13 13:39:40 -050093 gzip \
94 iproute2 \
95 ldd \
96 libaio \
97 logrotate \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050098 net-tools \
Andrew Geissler82c905d2020-04-13 13:39:40 -050099 perl \
100 python3-core \
101 procps \
102 quota \
103 unzip \
104 util-linux \
105 which \
106 tar \
107"
108
Patrick Williams213cb262021-08-07 19:21:33 -0500109FILES:${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500110
111# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
112INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
Patrick Williams213cb262021-08-07 19:21:33 -0500113INSANE_SKIP:${PN} += "already-stripped staticdev"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500114
Andrew Geisslerc926e172021-05-07 16:11:35 -0500115remove_broken_musl_sources() {
116 [ "${TCLIBC}" = "musl" ] || return 0
117
118 cd ${S}
119 echo "WARNING: remove unsupported tests (until they're fixed)"
120
121 # sync with upstream
122 # https://github.com/linux-test-project/ltp/blob/master/travis/alpine.sh#L33
123 rm -rfv \
124 testcases/kernel/sched/process_stress/process.c \
125 testcases/kernel/syscalls/confstr/confstr01.c \
126 testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \
127 testcases/kernel/syscalls/getcontext/getcontext01.c \
128 testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \
129 testcases/kernel/syscalls/timer_create/timer_create01.c \
130 testcases/kernel/syscalls/timer_create/timer_create03.c \
131 utils/benchmark/ebizzy-0.3
132}
133do_patch[postfuncs] += "remove_broken_musl_sources"
134
Andrew Geissler82c905d2020-04-13 13:39:40 -0500135# Avoid file dependency scans, as LTP checks for things that may or may not
136# exist on the running system. For instance it has specific checks for
137# csh and ksh which are not typically part of OpenEmbedded systems (but
138# can be added via additional layers.)
Patrick Williams213cb262021-08-07 19:21:33 -0500139SKIP_FILEDEPS:${PN} = '1'