blob: d9fbb5e9d64cc2fb2fe606924e15ccd69841377e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Hardware RNG based on CPU timing jitter"
2DESCRIPTION = "The Jitter RNG provides a noise source using the CPU execution timing jitter. \
3It does not depend on any system resource other than a high-resolution time \
4stamp. It is a small-scale, yet fast entropy source that is viable in almost \
5all environments and on a lot of CPU architectures."
6HOMEPAGE = "http://www.chronox.de/jent.html"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -05007LICENSE = "GPLv2+ | BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=1c94a9d191202a5552f381a023551396 \
9 file://LICENSE.gplv2;md5=eb723b61539feef013de476e68b5c50a \
10 file://LICENSE.bsd;md5=66a5cedaf62c4b2637025f049f9b826f \
Andrew Geissler82c905d2020-04-13 13:39:40 -050011 "
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050012SRC_URI = "git://github.com/smuellerDD/jitterentropy-library.git \
13 file://0001-Makefile-restore-build-reproducibility.patch \
14 "
15SRCREV = "409828cfccf4b3b07edc40a7840a821ce074e2c3"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016S = "${WORKDIR}/git"
17
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050018# remove at next version upgrade or when output changes
19PR = "r1"
20HASHEQUIV_HASH_VERSION .= ".2"
21
Andrew Geissler82c905d2020-04-13 13:39:40 -050022do_configure[noexec] = "1"
23
24LDFLAGS += "-Wl,-O0"
25
26do_install () {
27 oe_runmake install INCDIR="/include" \
28 DESTDIR="${D}" \
29 PREFIX="${exec_prefix}" \
30 LIBDIR="${baselib}" \
31 INSTALL_STRIP="install"
32}
33