blob: bdc636505260a0aef6fb0f180b24555e6f4248d9 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Ninja is a small build system with a focus on speed."
2HOMEPAGE = "http://martine.github.com/ninja/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
5
6DEPENDS = "re2c-native ninja-native"
7
8SRCREV = "ed7f67040b370189d989adbd60ff8ea29957231f"
9
10SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release"
11UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
12
13S = "${WORKDIR}/git"
14
15do_configure[noexec] = "1"
16
17do_compile_class-native() {
18 python3 ./configure.py --bootstrap
19}
20
21do_compile() {
22 python3 ./configure.py
23 ninja
24}
25
26do_install() {
27 install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
28}
29
30BBCLASSEXTEND = "native nativesdk"