blob: 03d0b0c6037d7905d01ffc20317e3865c391266f [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Protocol Buffers"
2HOMEPAGE = "https://developers.google.com/protocol-buffers/"
3SECTION = "devel/python"
4
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005LICENSE = "BSD-3-Clause"
Brad Bishop0f291cc2019-09-01 15:16:57 -04006LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de84f8d949cfcfd4e"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007
Andrew Geisslerc87764f2020-06-27 00:16:32 -05008inherit pypi setuptools3
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
Andrew Geisslerc87764f2020-06-27 00:16:32 -050010SRC_URI[md5sum] = "b4336acee38ebe915b6e72fe8c5bce7b"
11SRC_URI[sha256sum] = "49ef8ab4c27812a89a76fa894fe7a08f42f2147078392c0dee51d4a444ef6df5"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012
13# http://errors.yoctoproject.org/Errors/Details/184715/
14# Can't find required file: ../src/google/protobuf/descriptor.proto
15CLEANBROKEN = "1"
16
17UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/"
Brad Bishop316dfdd2018-06-25 12:45:53 -040018
Andrew Geisslerc87764f2020-06-27 00:16:32 -050019DEPENDS += "protobuf"
20
Brad Bishop316dfdd2018-06-25 12:45:53 -040021RDEPENDS_${PN} += " \
22 ${PYTHON_PN}-datetime \
23 ${PYTHON_PN}-json \
24 ${PYTHON_PN}-logging \
25 ${PYTHON_PN}-netclient \
26 ${PYTHON_PN}-numbers \
27 ${PYTHON_PN}-pkgutil \
28 ${PYTHON_PN}-six \
29 ${PYTHON_PN}-unittest \
30"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050031
32# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
Brad Bishop19323692019-04-05 15:28:33 -040033BBCLASSEXTEND = "native nativesdk"
34
Andrew Geisslerc87764f2020-06-27 00:16:32 -050035DISTUTILS_BUILD_ARGS += "--cpp_implementation"
36DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
37
38do_compile_prepend_class-native () {
39 export KOKORO_BUILD_NUMBER="1"
40}