blob: 0a4452eeac541f704d01c6cc32214591bc1430ae [file] [log] [blame]
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05301DESCRIPTION = "Security packagegroup for Poky"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6inherit packagegroup
7
8PACKAGES = "\
9 packagegroup-core-security \
10 packagegroup-security-utils \
11 packagegroup-security-scanners \
Andrew Geisslercc589282020-09-18 13:34:40 -050012 packagegroup-security-audit \
13 packagegroup-security-hardening \
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053014 packagegroup-security-ids \
15 packagegroup-security-mac \
Andrew Geisslerd1d22e62020-10-16 10:14:32 -050016 ${@bb.utils.contains("DISTRO_FEATURES", "ptest", "packagegroup-meta-security-ptest-packages", "", d)} \
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053017 "
18
19RDEPENDS_packagegroup-core-security = "\
20 packagegroup-security-utils \
21 packagegroup-security-scanners \
Andrew Geisslercc589282020-09-18 13:34:40 -050022 packagegroup-security-audit \
23 packagegroup-security-hardening \
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053024 packagegroup-security-ids \
25 packagegroup-security-mac \
Andrew Geisslerd1d22e62020-10-16 10:14:32 -050026 ${@bb.utils.contains("DISTRO_FEATURES", "ptest", "packagegroup-meta-security-ptest-packages", "", d)} \
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053027 "
28
29SUMMARY_packagegroup-security-utils = "Security utilities"
30RDEPENDS_packagegroup-security-utils = "\
31 checksec \
Andrew Geisslercc589282020-09-18 13:34:40 -050032 ding-libs \
33 ecryptfs-utils \
34 fscryptctl \
35 keyutils \
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053036 nmap \
37 pinentry \
Andrew Geisslercc589282020-09-18 13:34:40 -050038 python3-privacyidea \
39 python3-fail2ban \
Brad Bishop1fdf4aa2019-09-09 14:56:41 -040040 python3-scapy \
Andrew Geisslerd1d22e62020-10-16 10:14:32 -050041 softhsm \
42 libest \
43 opendnssec \
Andrew Geisslerb2fe8632020-08-21 15:57:21 -050044 ${@bb.utils.contains_any("TUNE_FEATURES", "riscv32 ", "", " libseccomp",d)} \
Andrew Geisslercc589282020-09-18 13:34:40 -050045 ${@bb.utils.contains("DISTRO_FEATURES", "pam", "sssd google-authenticator-libpam", "",d)} \
46 ${@bb.utils.contains("DISTRO_FEATURES", "pax", "pax-utils packctl", "",d)} \
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053047 "
48
49SUMMARY_packagegroup-security-scanners = "Security scanners"
50RDEPENDS_packagegroup-security-scanners = "\
Andrew Geisslercc589282020-09-18 13:34:40 -050051 isic \
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053052 nikto \
53 checksecurity \
Andrew Geisslerb2fe8632020-08-21 15:57:21 -050054 ${@bb.utils.contains_any("TUNE_FEATURES", "riscv32 riscv64", "", " clamav clamav-freshclam clamav-cvd",d)} \
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053055 "
Andrew Geisslerd1d22e62020-10-16 10:14:32 -050056RDEPENDS_packagegroup-security-scanners_remove_libc-musl = "clamav clamav-freshclam clamav-cvd"
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053057
58SUMMARY_packagegroup-security-audit = "Security Audit tools "
59RDEPENDS_packagegroup-security-audit = " \
60 buck-security \
61 redhat-security \
62 "
63
64SUMMARY_packagegroup-security-hardening = "Security Hardening tools"
65RDEPENDS_packagegroup-security-hardening = " \
66 bastille \
67 "
68
69SUMMARY_packagegroup-security-ids = "Security Intrusion Detection systems"
70RDEPENDS_packagegroup-security-ids = " \
71 tripwire \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080072 samhain-standalone \
Andrew Geisslercc589282020-09-18 13:34:40 -050073 ${@bb.utils.contains_any("TUNE_FEATURES", "ppc7400 riscv32 riscv64", "", " suricata",d)} \
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053074 "
75
76SUMMARY_packagegroup-security-mac = "Security Mandatory Access Control systems"
77RDEPENDS_packagegroup-security-mac = " \
78 ${@bb.utils.contains("DISTRO_FEATURES", "tomoyo", "ccs-tools", "",d)} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080079 ${@bb.utils.contains("DISTRO_FEATURES", "apparmor", "apparmor", "",d)} \
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053080 ${@bb.utils.contains("DISTRO_FEATURES", "smack", "smack", "",d)} \
81 "
Andrew Geisslerd1d22e62020-10-16 10:14:32 -050082
83RDEPENDS_packagegroup-meta-security-ptest-packages = "\
84 ptest-runner \
85 samhain-standalone-ptest \
86 libseccomp-ptest \
87 python3-scapy-ptest \
88 suricata-ptest \
89 tripwire-ptest \
90 python3-fail2ban-ptest \
91 ${@bb.utils.contains("DISTRO_FEATURES", "smack", "smack-ptest", "",d)} \
92"