blob: 0cf2d70b849dbea7ce20d53a7c22d9c79c19b843 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3SECTION = "security"
4LICENSE = "LGPL-2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
6
Andrew Geisslerb2fe8632020-08-21 15:57:21 -05007DEPENDS += "gperf-native"
Brad Bishopc342db32019-05-15 21:57:59 -04008
Andrew Geisslerb2fe8632020-08-21 15:57:21 -05009SRCREV = "f13f58efc690493fe7aa69f54cb52a118f3769c1"
10
11SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.5 \
Brad Bishopc342db32019-05-15 21:57:59 -040012 file://run-ptest \
Andrew Geisslerb2fe8632020-08-21 15:57:21 -050013 file://fix-mips-build-failure.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040014"
15
Andrew Geisslerb2fe8632020-08-21 15:57:21 -050016COMPATIBLE_HOST_riscv32 = "null"
17
Brad Bishopc342db32019-05-15 21:57:59 -040018S = "${WORKDIR}/git"
19
20inherit autotools-brokensep pkgconfig ptest
21
22PACKAGECONFIG ??= ""
Andrew Geisslerb2fe8632020-08-21 15:57:21 -050023PACKAGECONFIG[python] = "--enable-python, --disable-python, python3"
Brad Bishopc342db32019-05-15 21:57:59 -040024
Brad Bishop1fdf4aa2019-09-09 14:56:41 -040025DISABLE_STATIC = ""
26
Brad Bishopc342db32019-05-15 21:57:59 -040027do_compile_ptest() {
28 oe_runmake -C tests check-build
29}
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}/tests
33 install -d ${D}${PTEST_PATH}/tools
34 for file in $(find tests/* -executable -type f); do
35 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
36 done
37 for file in $(find tests/*.tests -type f); do
38 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
39 done
40 for file in $(find tools/* -executable -type f); do
41 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
42 done
43}
44
45FILES_${PN} = "${bindir} ${libdir}/${BPN}.so*"
46FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
47
Andrew Geisslerd1d22e62020-10-16 10:14:32 -050048RDEPENDS_${PN}-ptest = "coreutils bash"