blob: 5e42ca8f74ec0904a2d19874dfdd1857fe9a2019 [file] [log] [blame]
Andrew Geisslerd1d22e62020-10-16 10:14:32 -05001SUMMARY = "OpenDNSSEC is a policy-based zone signer that automates the process of keeping track of DNSSEC keys and the signing of zones"
2
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b041dbe2da80d4efd951393fbba90937"
5
6DEPENDS = "libxml2 openssl ldns libmicrohttpd jansson libyaml "
7
8SRC_URI = "git://github.com/opendnssec/opendnssec;branch=develop \
9 file://libxml2_conf.patch \
10 file://libdns_conf_fix.patch \
11 file://fix_fprint.patch \
12 "
13
14SRCREV = "5876bccb38428790e2e9afc806ca68b029879874"
15
16inherit autotools pkgconfig perlnative
17
18S = "${WORKDIR}/git"
19
20EXTRA_OECONF = " --with-libxml2=${STAGING_DIR_HOST}/usr --with-ldns=${STAGING_DIR_HOST}/usr \
21 --with-ssl=${STAGING_DIR_HOST}/usr "
22
23CFLAGS += "-fcommon"
24
25PACKAGECONFIG ?= "sqlite3"
26
27PACKAGECONFIG[cunit] = "--with-cunit=${STAGING_DIR_HOST}/usr, --without-cunit,"
28PACKAGECONFIG[sqlite3] = "--with-sqlite3=${STAGING_DIR_HOST}/usr, ,sqlite3, sqlite3"
29PACKAGECONFIG[mysql] = "--with-mysql=yes, , mariadb, mariadb"
30PACKAGECONFIG[readline] = "--with-readline, --without-readline, readline"
31PACKAGECONFIG[unwind] = "--with-libunwind, --without-libunwind"
32
33do_install_append () {
34 rm -rf ${D}${localstatedir}/run
35}
36
37RDEPENDS_${PN} = "softhsm"