blob: 74e837aa5e0f220ef82afaaeceaadcdefdb4f96d [file] [log] [blame]
Andrew Geisslerd1d22e62020-10-16 10:14:32 -05001SUMMARY = "SoftHSM is an implementation of a cryptographic store accessible through a PKCS #11 interface."
2HOMEPAGE = "www.opendnssec.org"
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210"
6
7DEPENDS = "sqlite3"
8
9SRC_URI = "https://dist.opendnssec.org/source/softhsm-2.6.1.tar.gz"
10SRC_URI[sha256sum] = "61249473054bcd1811519ef9a989a880a7bdcc36d317c9c25457fc614df475f2"
11
12inherit autotools pkgconfig siteinfo
13
14EXTRA_OECONF += " --with-sqlite3=${STAGING_DIR_HOST}/usr"
15EXTRA_OECONF += "${@oe.utils.conditional('SITEINFO_BITS', '64', ' --enable-64bit', '', d)}"
16
17PACKAGECONFIG ?= "pk11 openssl"
18
19PACKAGECONFIG[npm] = ",--disable-non-paged-memory"
20PACKAGECONFIG[ecc] = "--enable-ecc,--disable-ecc"
21PACKAGECONFIG[gost] = "--enable-gost,--disable-gost"
22PACKAGECONFIG[eddsa] = "--enable-eddsa, --disable-eddsa"
23PACKAGECONFIG[fips] = "--enable-fips, --disable-fips"
24PACKAGECONFIG[notvisable] = "--disable-visibility"
25PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}/usr --with-crypto-backend=openssl, --without-openssl, openssl, openssl"
26PACKAGECONFIG[botan] = "--with-botan=${STAGING_DIR_HOST}/usr --with-crypto-backend=botan, --without-botan, botan"
27PACKAGECONFIG[migrate] = "--with-migrate"
28PACKAGECONFIG[pk11] = "--enable-p11-kit --with-p11-kit==${STAGING_DIR_HOST}/usr, --without-p11-kit, p11-kit, p11-kit"
29
30RDEPENDS_${PN} = "sqlite3"