blob: 320f93bdc20362952aa5719209a79a12a2517ee5 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "The basic file, shell and text manipulation utilities"
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
7LICENSE = "GPLv3+"
Andrew Geissler4b740dc2020-05-05 08:54:39 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
9 file://src/ls.c;beginline=1;endline=15;md5=b7d80abf5b279320fb0e4b1007ed108b \
10 "
Brad Bishopc342db32019-05-15 21:57:59 -040011DEPENDS = "gmp libcap"
12DEPENDS_class-native = ""
13
14inherit autotools gettext texinfo
15
16SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
17 file://remove-usr-local-lib-from-m4.patch \
18 file://fix-selinux-flask.patch \
19 file://0001-uname-report-processor-and-hardware-correctly.patch \
20 file://disable-ls-output-quoting.patch \
21 file://0001-local.mk-fix-cross-compiling-problem.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 file://run-ptest \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050023 file://0001-ls-restore-8.31-behavior-on-removed-directories.patch \
24 "
Brad Bishopc342db32019-05-15 21:57:59 -040025
Andrew Geissler4b740dc2020-05-05 08:54:39 -050026SRC_URI[md5sum] = "022042695b7d5bcf1a93559a9735e668"
27SRC_URI[sha256sum] = "4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa"
Brad Bishopc342db32019-05-15 21:57:59 -040028
29EXTRA_OECONF_class-native = "--without-gmp"
30EXTRA_OECONF_class-target = "--enable-install-program=arch,hostname --libexecdir=${libdir}"
31EXTRA_OECONF_class-nativesdk = "--enable-install-program=arch,hostname"
32
33# acl and xattr are not default features
34#
35PACKAGECONFIG_class-target ??= "\
36 ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \
37"
38
39# The lib/oe/path.py requires xattr
40PACKAGECONFIG_class-native ??= "xattr"
41
Andrew Geisslerd1e89492021-02-12 15:35:20 -060042# oe-core builds need xattr support
43PACKAGECONFIG_class-nativesdk ??= "xattr"
44
Brad Bishopc342db32019-05-15 21:57:59 -040045# with, without, depends, rdepends
46#
47PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
48PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
49PACKAGECONFIG[single-binary] = "--enable-single-binary,--disable-single-binary,,"
50
51# [ df mktemp nice printenv base64 gets a special treatment and is not included in this
52bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname du \
53 env expand expr factor fmt fold groups head hostid id install \
54 join link logname md5sum mkfifo nl nohup nproc od paste pathchk \
55 pinky pr printf ptx readlink realpath runcon seq sha1sum sha224sum sha256sum \
Brad Bishop64c979e2019-11-04 13:55:29 -050056 sha384sum sha512sum shred shuf sort split sum tac tail tee test timeout \
Brad Bishopc342db32019-05-15 21:57:59 -040057 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
58
59# hostname gets a special treatment and is not included in this
60base_bindir_progs = "cat chgrp chmod chown cp date dd echo false hostname kill ln ls mkdir \
61 mknod mv pwd rm rmdir sleep stty sync touch true uname stat"
62
63sbindir_progs= "chroot"
64
Andrew Geissler475cb722020-07-10 16:00:51 -050065# Split stdbuf into its own package, so one can include
66# coreutils-stdbuf without getting the rest of coreutils, but make
67# coreutils itself pull in stdbuf, so IMAGE_INSTALL += "coreutils"
68# always provides all coreutils
69PACKAGE_BEFORE_PN_class-target += "${@bb.utils.contains('PACKAGECONFIG', 'single-binary', '', 'coreutils-stdbuf', d)}"
Brad Bishop64c979e2019-11-04 13:55:29 -050070FILES_coreutils-stdbuf = "${bindir}/stdbuf ${libdir}/coreutils/libstdbuf.so"
Andrew Geissler475cb722020-07-10 16:00:51 -050071RDEPENDS_coreutils_class-target += "${@bb.utils.contains('PACKAGECONFIG', 'single-binary', '', 'coreutils-stdbuf', d)}"
72
73# However, when the single-binary PACKAGECONFIG is used, stdbuf
74# functionality is built into the single coreutils binary, so there's
75# no point splitting /usr/bin/stdbuf to its own package. Instead, add
76# an RPROVIDE so that rdepending on coreutils-stdbuf will work
77# regardless of whether single-binary is in effect.
78RPROVIDES_coreutils += "${@bb.utils.contains('PACKAGECONFIG', 'single-binary', 'coreutils-stdbuf', '', d)}"
Brad Bishop64c979e2019-11-04 13:55:29 -050079
Brad Bishopc342db32019-05-15 21:57:59 -040080# Let aclocal use the relative path for the m4 file rather than the
81# absolute since coreutils has a lot of m4 files, otherwise there might
82# be an "Argument list too long" error when it is built in a long/deep
83# directory.
84acpaths = "-I ./m4"
85
86# Deal with a separate builddir failure if src doesn't exist when creating version.c/version.h
87do_compile_prepend () {
88 mkdir -p ${B}/src
89}
90
91do_install_class-native() {
92 autotools_do_install
93 # remove groups to fix conflict with shadow-native
94 rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
95 # The return is a must since native doesn't need the
96 # do_install_append() in the below.
97 return
98}
99
100do_install_append() {
101 for i in df mktemp nice printenv base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
102
103 install -d ${D}${base_bindir}
104 [ "${base_bindir}" != "${bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${BPN}; done
105
106 install -d ${D}${sbindir}
107 [ "${sbindir}" != "${bindir}" ] && for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${BPN}; done
108
109 # [ requires special handling because [.coreutils will cause the sed stuff
110 # in update-alternatives to fail, therefore use lbracket - the name used
111 # for the actual source file.
112 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${BPN}
113}
114
115inherit update-alternatives
116
117ALTERNATIVE_PRIORITY = "100"
118# Make hostname's priority higher than busybox but lower than net-tools
119ALTERNATIVE_PRIORITY[hostname] = "90"
120ALTERNATIVE_${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base64 nice printenv mktemp df"
121ALTERNATIVE_${PN}-doc = "base64.1 nice.1 mktemp.1 df.1 groups.1 kill.1 uptime.1 stat.1 hostname.1"
122
123ALTERNATIVE_LINK_NAME[hostname.1] = "${mandir}/man1/hostname.1"
124
125ALTERNATIVE_LINK_NAME[base64] = "${base_bindir}/base64"
126ALTERNATIVE_TARGET[base64] = "${bindir}/base64.${BPN}"
127ALTERNATIVE_LINK_NAME[base64.1] = "${mandir}/man1/base64.1"
128
129ALTERNATIVE_LINK_NAME[mktemp] = "${base_bindir}/mktemp"
130ALTERNATIVE_TARGET[mktemp] = "${bindir}/mktemp.${BPN}"
131ALTERNATIVE_LINK_NAME[mktemp.1] = "${mandir}/man1/mktemp.1"
132
133ALTERNATIVE_LINK_NAME[df] = "${base_bindir}/df"
134ALTERNATIVE_TARGET[df] = "${bindir}/df.${BPN}"
135ALTERNATIVE_LINK_NAME[df.1] = "${mandir}/man1/df.1"
136
137ALTERNATIVE_LINK_NAME[nice] = "${base_bindir}/nice"
138ALTERNATIVE_TARGET[nice] = "${bindir}/nice.${BPN}"
139ALTERNATIVE_LINK_NAME[nice.1] = "${mandir}/man1/nice.1"
140
141ALTERNATIVE_LINK_NAME[printenv] = "${base_bindir}/printenv"
142ALTERNATIVE_TARGET[printenv] = "${bindir}/printenv.${BPN}"
143
144ALTERNATIVE_LINK_NAME[lbracket] = "${bindir}/["
145ALTERNATIVE_TARGET[lbracket] = "${bindir}/lbracket.${BPN}"
146
147ALTERNATIVE_LINK_NAME[groups.1] = "${mandir}/man1/groups.1"
148ALTERNATIVE_LINK_NAME[uptime.1] = "${mandir}/man1/uptime.1"
149ALTERNATIVE_LINK_NAME[kill.1] = "${mandir}/man1/kill.1"
150ALTERNATIVE_LINK_NAME[stat.1] = "${mandir}/man1/stat.1"
151
152python __anonymous() {
153 for prog in d.getVar('base_bindir_progs').split():
154 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir'), prog))
155
156 for prog in d.getVar('sbindir_progs').split():
157 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('sbindir'), prog))
158}
159
160BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500161
162inherit ptest
163
Andrew Geisslerf0343792020-11-18 10:42:21 -0600164RDEPENDS_${PN}-ptest += "bash findutils gawk liberror-perl make perl perl-modules python3-core sed shadow"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500165
166# -dev automatic dependencies fails as we don't want libmodule-build-perl-dev, its too heavy
167# may need tweaking if DEPENDS changes
168RRECOMMENDS_coreutils-dev[nodeprrecs] = "1"
169RRECOMMENDS_coreutils-dev = "acl-dev attr-dev gmp-dev libcap-dev bash-dev findutils-dev gawk-dev shadow-dev"
170
171do_install_ptest () {
172 install -d ${D}${PTEST_PATH}/tests
173 cp -r ${S}/tests/* ${D}${PTEST_PATH}/tests
174 sed -i 's/ginstall/install/g' `grep -R ginstall ${D}${PTEST_PATH}/tests | awk -F: '{print $1}' | uniq`
175 install -d ${D}${PTEST_PATH}/build-aux
176 install ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
177 cp ${B}/Makefile ${D}${PTEST_PATH}/
178 cp ${S}/init.cfg ${D}${PTEST_PATH}/
179 cp -r ${B}/src ${D}${PTEST_PATH}/
180 cp -r ${S}/src/*.c ${D}${PTEST_PATH}/src
181 sed -i '/^VPATH/s/= .*$/= ./g' ${D}${PTEST_PATH}/Makefile
182 sed -i '/^PROGRAMS/s/^/#/g' ${D}${PTEST_PATH}/Makefile
183 sed -i '/^Makefile: /s/^.*$/Makefile:/g' ${D}${PTEST_PATH}/Makefile
184 sed -i '/^abs_srcdir/s/= .*$/= \$\{PWD\}/g' ${D}${PTEST_PATH}/Makefile
185 sed -i '/^abs_top_builddir/s/= .*$/= \$\{PWD\}/g' ${D}${PTEST_PATH}/Makefile
186 sed -i '/^abs_top_srcdir/s/= .*$/= \$\{PWD\}/g' ${D}${PTEST_PATH}/Makefile
187 sed -i '/^built_programs/s/ginstall/install/g' ${D}${PTEST_PATH}/Makefile
188 chmod -R 777 ${D}${PTEST_PATH}
189
190 # Disable subcase stty-pairs.sh, it will cause test framework hang
191 sed -i '/stty-pairs.sh/d' ${D}${PTEST_PATH}/Makefile
192
193 # Disable subcase tail-2/assert.sh as it has issues on 32-bit systems
194 sed -i '/assert.sh/d' ${D}${PTEST_PATH}/Makefile
195
196 # Tweak test d_type-check to use python3 instead of python
197 sed -i "1s@.*@#!/usr/bin/python3@" ${D}${PTEST_PATH}/tests/d_type-check
198 install ${B}/src/getlimits ${D}/${bindir}
199
200 # handle multilib
201 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
202}
203
204FILES_${PN}-ptest += "${bindir}/getlimits"
Andrew Geissler09209ee2020-12-13 08:44:15 -0600205
206# These are specific to Opensuse
207CVE_WHITELIST += "CVE-2013-0221 CVE-2013-0222 CVE-2013-0223"