blob: db59189fa0e0b06d653456a0441b62195c0bdfaa [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Disk partition editing/resizing utility"
2HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c"
5SECTION = "console/tools"
Andrew Geisslerd1e89492021-02-12 15:35:20 -06006DEPENDS = "ncurses util-linux virtual/libiconv"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
9 file://no_check.patch \
10 file://fix-doc-mandir.patch \
11 file://0002-libparted_fs_resize-link-against-libuuid-explicitly-.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050012 file://run-ptest \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 "
14
Andrew Geisslerd1e89492021-02-12 15:35:20 -060015SRC_URI[md5sum] = "357d19387c6e7bc4a8a90fe2d015fe80"
16SRC_URI[sha256sum] = "e1298022472da5589b7f2be1d5ee3c1b66ec3d96dfbad03dc642afd009da5342"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18EXTRA_OECONF = "--disable-device-mapper"
19
20inherit autotools pkgconfig gettext texinfo ptest
21
Andrew Geisslerd1e89492021-02-12 15:35:20 -060022PACKAGECONFIG ?= "readline"
23PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
24
Andrew Geissler5a43b432020-06-13 10:46:56 -050025BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050026
27do_compile_ptest() {
28 oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize print-flags
29}
30
31do_install_ptest() {
32 t=${D}${PTEST_PATH}
33 mkdir $t/build-aux
34 cp ${S}/build-aux/test-driver $t/build-aux/
35 cp -r ${S}/tests $t
36 cp ${B}/tests/Makefile $t/tests/
37 sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile
38 sed -i "s|^srcdir =.*|srcdir = \.|g" $t/tests/Makefile
39 sed -i "s|^abs_srcdir =.*|abs_srcdir = \.|g" $t/tests/Makefile
40 sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = \.\.|g" $t/tests/Makefile
41 sed -i "s|^Makefile:.*|Makefile:|g" $t/tests/Makefile
42 for i in print-align print-max print-flags dup-clobber duplicate fs-resize; \
43 do cp ${B}/tests/.libs/$i $t/tests/; \
44 done
45 sed -e 's| ../parted||' -i $t/tests/*.sh
46}
47
Andrew Geisslerd1e89492021-02-12 15:35:20 -060048RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make gawk e2fsprogs-mke2fs python3-core"
Andrew Geisslerf0343792020-11-18 10:42:21 -060049RRECOMMENDS_${PN}-ptest = "kernel-module-scsi-debug"
Andrew Geissler82c905d2020-04-13 13:39:40 -050050RDEPENDS_${PN}-ptest_append_libc-glibc = "\
51 glibc-utils \
52 locale-base-en-us \
53 "
54
55inherit update-alternatives
56
57ALTERNATIVE_PRIORITY = "100"
58ALTERNATIVE_${PN} = "partprobe"
59ALTERNATIVE_LINK_NAME[partprobe] = "${sbindir}/partprobe"