blob: fe21dbcf50e152657be541bab144ad1d9003d007 [file] [log] [blame]
Andrew Geisslerd1e89492021-02-12 15:35:20 -06001SUMMARY = "OpenGL / OpenGL ES Reference Compiler"
2DESCRIPTION = "Glslang is the official reference compiler front end for the \
3OpenGL ES and OpenGL shading languages. It implements a strict interpretation \
4of the specifications for these languages. It is open and free for anyone to use, \
5either from a command line or programmatically."
6SECTION = "graphics"
7HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
8LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c5ce49c0456e9b413b98a4368c378229"
10
11SRCREV = "c594de23cdd790d64ad5f9c8b059baae0ee2941d"
12SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https"
13UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)$"
14S = "${WORKDIR}/git"
15
16inherit cmake python3native
17
18EXTRA_OECMAKE = " \
19 -DCMAKE_BUILD_TYPE=Release \
20 -DBUILD_SHARED_LIBS=ON \
21 -DENABLE_PCH=OFF \
22 -DENABLE_CTEST=OFF \
23 -DBUILD_EXTERNAL=OFF \
24"
25
26SOLIBSDEV = "glslang.so"
27FILES_${PN} += "${libdir}/*.so"
28
29BBCLASSEXTEND = "native nativesdk"