blob: a404fe2852d0fe05a3484fd6e011b1f55d4bd67d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "OpenGL function pointer management library"
2DESCRIPTION = "It hides the complexity of dlopen(), dlsym(), \
3glXGetProcAddress(), eglGetProcAddress(), etc. from the app developer, with \
4very little knowledge needed on their part. They get to read GL specs and \
5write code using undecorated function names like glCompileShader()."
6HOMEPAGE = "https://github.com/anholt/libepoxy/"
7SECTION = "libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b"
11
12SRC_URI = "https://github.com/anholt/${BPN}/releases/download/${PV}/${BP}.tar.xz \
13 file://0001-dispatch_common.h-define-also-EGL_NO_X11.patch \
14 "
Andrew Geisslerd1e89492021-02-12 15:35:20 -060015SRC_URI[sha256sum] = "261663db21bcc1cc232b07ea683252ee6992982276536924271535875f5b0556"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016UPSTREAM_CHECK_URI = "https://github.com/anholt/libepoxy/releases"
17
18inherit meson pkgconfig features_check
19
20REQUIRED_DISTRO_FEATURES = "opengl"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22PACKAGECONFIG[egl] = "-Degl=yes, -Degl=no, virtual/egl"
23PACKAGECONFIG[x11] = "-Dglx=yes, -Dglx=no -Dx11=false, virtual/libx11 virtual/libgl"
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} egl"
25
26EXTRA_OEMESON += "-Dtests=false"
27
28PACKAGECONFIG_class-native = "egl x11"
29PACKAGECONFIG_class-nativesdk = "egl x11"
30
31BBCLASSEXTEND = "native nativesdk"
32