blob: 05b9e855d78ff9189e8813a26f3ef47e8ea6c426 [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
2LICENSE = "Apache-2.0"
3
4LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
5
6SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git \
7 file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -06008 file://debugfix.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -06009 "
10
11UPSTREAM_CHECK_COMMITS = "1"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060012SRCREV = "524cdcd27005e7cd56e6694fa41e685519d7dbca"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060013
14UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
15S = "${WORKDIR}/git"
16
17REQUIRED_DISTRO_FEATURES = 'vulkan'
18
19inherit cmake features_check
20
21FILES_${PN} += "${datadir}"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060022
23#
24# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
25# used for logging with LOGE in the code. We need to make this match the value we use
26# in the debug source remapping from CFLAGS
27#
28EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
29# Binaries built with PCH enabled don't appear reproducible, differing results were seen
30# from some builds depending on the point the PCH was compiled. Disable it to be
31# deterministic
32EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"