blob: 2c219c2a12c27dcaf21123816310d225f1deb0af [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "A low level cryptographic library"
2HOMEPAGE = "http://www.lysator.liu.se/~nisse/nettle/"
Andrew Geisslerd1e89492021-02-12 15:35:20 -06003DESCRIPTION = "It tries to solve a problem of providing a common set of \
4cryptographic algorithms for higher-level applications by implementing a \
5context-independent set of cryptographic algorithms"
Brad Bishop19323692019-04-05 15:28:33 -04006SECTION = "libs"
7LICENSE = "LGPLv3+ | GPLv2+"
8
9LIC_FILES_CHKSUM = "file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
10 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
11 file://serpent-decrypt.c;beginline=14;endline=36;md5=ca0d220bc413e1842ecc507690ce416e \
12 file://serpent-set-key.c;beginline=14;endline=36;md5=ca0d220bc413e1842ecc507690ce416e"
13
14DEPENDS += "gmp"
15
16SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
17 file://Add-target-to-only-build-tests-not-run-them.patch \
18 file://run-ptest \
19 file://check-header-files-of-openssl-only-if-enable_.patch \
20 "
21
22SRC_URI_append_class-target = "\
23 file://dlopen-test.patch \
24 "
25
Andrew Geisslerd1e89492021-02-12 15:35:20 -060026SRC_URI[sha256sum] = "f001f64eb444bf13dd91bceccbc20acbc60c4311d6e2b20878452eb9a9cec75a"
Brad Bishop19323692019-04-05 15:28:33 -040027
28UPSTREAM_CHECK_REGEX = "nettle-(?P<pver>\d+(\.\d+)+)\.tar"
29
30inherit autotools ptest multilib_header
31
32EXTRA_AUTORECONF += "--exclude=aclocal"
33
34EXTRA_OECONF = "--disable-openssl"
Brad Bishop19323692019-04-05 15:28:33 -040035
36do_compile_ptest() {
37 oe_runmake buildtest
38}
39
40do_install_append() {
Brad Bishop08902b02019-08-20 09:16:51 -040041 oe_multilib_header nettle/version.h
Brad Bishop19323692019-04-05 15:28:33 -040042}
43
44do_install_ptest() {
45 install -d ${D}${PTEST_PATH}/testsuite/
46 install ${S}/testsuite/gold-bug.txt ${D}${PTEST_PATH}/testsuite/
47 install ${S}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
48 # tools can be found in PATH, not in ../tools/
49 sed -i -e 's|../tools/||' ${D}${PTEST_PATH}/testsuite/*-test
50 install ${B}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
51}
52
Brad Bishopc342db32019-05-15 21:57:59 -040053RDEPENDS_${PN}-ptest += "${PN}-dev"
54INSANE_SKIP_${PN}-ptest += "dev-deps"
55
Brad Bishop19323692019-04-05 15:28:33 -040056BBCLASSEXTEND = "native nativesdk"