blob: 47c9a64aab1beda360d26095e4ddaef87bb42248 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "This is a filesystem client based on the SSH File Transfer Protocol using FUSE"
2AUTHOR = "Miklos Szeredi <miklos@szeredi.hu>"
3HOMEPAGE = "https://github.com/libfuse/sshfs"
4SECTION = "console/network"
5LICENSE = "GPLv2"
6DEPENDS = "glib-2.0 fuse3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9SRC_URI = "git://github.com/libfuse/sshfs"
10SRCREV = "a7e1038203c856cc7e052d439d1da49fe131339f"
11S = "${WORKDIR}/git"
12
Andrew Geisslerd221e032020-07-10 16:13:21 -050013inherit meson ptest
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS_${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21 bash \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/test
26 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
27}