blob: 3a1222e89e4046e18490bc41365a1473a7aa2ef5 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Paho MQTT - C libraries for the MQTT and MQTT-SN protocols"
2DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)."
3HOMEPAGE = "http://www.eclipse.org/paho/"
4SECTION = "console/network"
Andrew Geisslere231d582020-05-05 08:53:09 -05005LICENSE = "EPL-2.0 | EDL-1.0"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
7LIC_FILES_CHKSUM = " \
Andrew Geisslere231d582020-05-05 08:53:09 -05008 file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \
9 file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \
10 file://notice.html;md5=943f861069889acecebf51dfa24478e2 \
11 file://about.html;md5=e5662cbb5f8fd5c9faac526e4077898e \
Andrew Geissler82c905d2020-04-13 13:39:40 -050012"
13
14SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=http \
15 file://0001-Fix-bug-of-free-with-musl.patch"
16
Andrew Geisslere231d582020-05-05 08:53:09 -050017SRCREV = "3148fe2d5f4b87e16266dfe559c0764e16ca0546"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
19DEPENDS = "openssl"
20
21S = "${WORKDIR}/git"
22
23inherit cmake
24
Andrew Geisslerd221e032020-07-10 16:13:21 -050025do_configure_prepend() {
26 sed -i s:\ lib/cmake:\ ${baselib}/cmake:g ${S}/src/CMakeLists.txt
27}
28
Andrew Geissler82c905d2020-04-13 13:39:40 -050029do_install_append() {
30 # paho-mqtt installes some thing that we don't want.
31 rm -rf ${D}${prefix}/samples
32 find ${D}${prefix} -maxdepth 1 -type f -delete
33}
34
35EXTRA_OECMAKE = "-DPAHO_WITH_SSL=ON"