blob: 3b9cd52f2c00b3338a669cdc3832dcdfcae6ae1b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "Modern password hashing for your software and your servers."
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
4
5DEPENDS += "${PYTHON_PN}-cffi-native"
6
7SRC_URI[md5sum] = "5d6f93b575ce52470af37a8e7dce76fe"
8SRC_URI[sha256sum] = "0b0069c752ec14172c5f78208f1863d7ad6755a6fae6fe76ec2c80d13be41e42"
9
Andrew Geisslerd221e032020-07-10 16:13:21 -050010inherit pypi setuptools3 ptest
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS_${PN}-ptest += " \
17 ${PYTHON_PN}-pytest \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25RDEPENDS_${PN}_class-target += "\
26 ${PYTHON_PN}-cffi \
27 ${PYTHON_PN}-ctypes \
28 ${PYTHON_PN}-shell \
29 ${PYTHON_PN}-six \
30"