blob: 0b513e7cb982c95e8d44c70d95209ce8a4d63818 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
2DESCRIPTION = "\
3Click is a Python package for creating beautiful command line interfaces \
4in a composable way with as little code as necessary. It's the "Command \
5Line Interface Creation Kit". It's highly configurable but comes with \
6sensible defaults out of the box."
7HOMEPAGE = "http://click.pocoo.org/"
8LICENSE = "BSD-3-Clause"
Andrew Geisslereafcbb82020-06-05 17:59:17 -05009LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
Andrew Geisslereafcbb82020-06-05 17:59:17 -050011SRC_URI[md5sum] = "53692f62cb99a1a10c59248f1776d9c0"
12SRC_URI[sha256sum] = "d2b5255c7c6349bc1bd1e59e08cd12acbbd63ce649f2588755783aa94dfb6b1a"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
Andrew Geisslerd221e032020-07-10 16:13:21 -050014inherit pypi setuptools3 ptest
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20RDEPENDS_${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22 ${PYTHON_PN}-terminal \
23 ${PYTHON_PN}-unixadmin \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}
Andrew Geissler82c905d2020-04-13 13:39:40 -050030
31UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
32
33CLEANBROKEN = "1"
34
35RDEPENDS_${PN} += "\
36 ${PYTHON_PN}-io \
37 ${PYTHON_PN}-threading \
38 "
39
40BBCLASSEXTEND = "native nativesdk"