blob: 4162c4e79002d65ecee920786f81789a866888c9 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001# Help runqemu boot target board, "QB" means Qemu Boot, the following
2# vars can be set in conf files, such as <bsp.conf> to make it can be
3# boot by runqemu:
4#
5# QB_SYSTEM_NAME: qemu name, e.g., "qemu-system-i386"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006#
Andrew Geisslerd25ed322020-06-27 00:28:28 -05007# QB_OPT_APPEND: options to append to qemu, e.g., "-device usb-mouse"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008#
Patrick Williamsc0f7c042017-02-23 20:41:17 -06009# QB_DEFAULT_KERNEL: default kernel to boot, e.g., "bzImage"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060011# QB_DEFAULT_FSTYPE: default FSTYPE to boot, e.g., "ext4"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060013# QB_MEM: memory, e.g., "-m 512"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060015# QB_MACHINE: qemu machine, e.g., "-machine virt"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060017# QB_CPU: qemu cpu, e.g., "-cpu qemu32"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060019# QB_CPU_KVM: the similar to QB_CPU, but used when kvm, e.g., '-cpu kvm64',
20# set it when support kvm.
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060022# QB_KERNEL_CMDLINE_APPEND: options to append to kernel's -append
23# option, e.g., "console=ttyS0 console=tty"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060025# QB_DTB: qemu dtb name
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060027# QB_AUDIO_DRV: qemu audio driver, e.g., "alsa", set it when support audio
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060029# QB_AUDIO_OPT: qemu audio option, e.g., "-soundhw ac97,es1370", used
30# when QB_AUDIO_DRV is set.
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060032# QB_KERNEL_ROOT: kernel's root, e.g., /dev/vda
Brad Bishop6e60e8b2018-02-01 10:27:11 -050033#
34# QB_NETWORK_DEVICE: network device, e.g., "-device virtio-net-pci,netdev=net0,mac=@MAC@",
35# it needs work with QB_TAP_OPT and QB_SLIRP_OPT.
36# Note, runqemu will replace @MAC@ with a predefined mac, you can set
37# a custom one, but that may cause conflicts when multiple qemus are
38# running on the same host.
Andrew Geissler82c905d2020-04-13 13:39:40 -050039# Note: If more than one interface of type -device virtio-net-device gets added,
40# QB_NETWORK_DEVICE_prepend might be used, since Qemu enumerates the eth*
41# devices in reverse order to -device arguments.
Brad Bishop6e60e8b2018-02-01 10:27:11 -050042#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060043# QB_TAP_OPT: netowrk option for 'tap' mode, e.g.,
Brad Bishop6e60e8b2018-02-01 10:27:11 -050044# "-netdev tap,id=net0,ifname=@TAP@,script=no,downscript=no"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060045# Note, runqemu will replace "@TAP@" with the one which is used, such as tap0, tap1 ...
Brad Bishop6e60e8b2018-02-01 10:27:11 -050046#
47# QB_SLIRP_OPT: network option for SLIRP mode, e.g., -netdev user,id=net0"
48#
Andrew Geissler82c905d2020-04-13 13:39:40 -050049# QB_CMDLINE_IP_SLIRP: If QB_NETWORK_DEVICE adds more than one network interface to qemu, usually the
50# ip= kernel comand line argument needs to be changed accordingly. Details are documented
51# in the kernel docuemntation https://www.kernel.org/doc/Documentation/filesystems/nfs/nfsroot.txt
52# Example to configure only the first interface: "ip=eth0:dhcp"
53# QB_CMDLINE_IP_TAP: This parameter is similar to the QB_CMDLINE_IP_SLIRP parameter. Since the tap interface requires
54# static IP configuration @CLIENT@ and @GATEWAY@ place holders are replaced by the IP and the gateway
55# address of the qemu guest by runqemu.
56# Example: "ip=192.168.7.@CLIENT@::192.168.7.@GATEWAY@:255.255.255.0::eth0"
57#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060058# QB_ROOTFS_OPT: used as rootfs, e.g.,
59# "-drive id=disk0,file=@ROOTFS@,if=none,format=raw -device virtio-blk-device,drive=disk0"
60# Note, runqemu will replace "@ROOTFS@" with the one which is used, such as core-image-minimal-qemuarm64.ext4.
Brad Bishop6e60e8b2018-02-01 10:27:11 -050061#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060062# QB_SERIAL_OPT: serial port, e.g., "-serial mon:stdio"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050063#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060064# QB_TCPSERIAL_OPT: tcp serial port option, e.g.,
65# " -device virtio-serial-device -chardev socket,id=virtcon,port=@PORT@,host=127.0.0.1 -device virtconsole,chardev=virtcon"
66# Note, runqemu will replace "@PORT@" with the port number which is used.
67#
Andrew Geissler82c905d2020-04-13 13:39:40 -050068# QB_ROOTFS_EXTRA_OPT: extra options to be appended to the rootfs device in case there is none specified by QB_ROOTFS_OPT.
69# Can be used to automatically determine the image from the other variables
70# but define things link 'bootindex' when booting from EFI or 'readonly' when using squashfs
71# without the need to specify a dedicated qemu configuration
Patrick Williamsc0f7c042017-02-23 20:41:17 -060072# Usage:
73# IMAGE_CLASSES += "qemuboot"
74# See "runqemu help" for more info
75
76QB_MEM ?= "-m 256"
77QB_SERIAL_OPT ?= "-serial mon:stdio -serial null"
78QB_DEFAULT_KERNEL ?= "${KERNEL_IMAGETYPE}"
79QB_DEFAULT_FSTYPE ?= "ext4"
Andrew Geisslerd25ed322020-06-27 00:28:28 -050080QB_OPT_APPEND ?= ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050081QB_NETWORK_DEVICE ?= "-device virtio-net-pci,netdev=net0,mac=@MAC@"
Andrew Geissler82c905d2020-04-13 13:39:40 -050082QB_CMDLINE_IP_SLIRP ?= "ip=dhcp"
83QB_CMDLINE_IP_TAP ?= "ip=192.168.7.@CLIENT@::192.168.7.@GATEWAY@:255.255.255.0"
84QB_ROOTFS_EXTRA_OPT ?= ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050085
86# This should be kept align with ROOT_VM
87QB_DRIVE_TYPE ?= "/dev/sd"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060088
89# Create qemuboot.conf
Brad Bishop6e60e8b2018-02-01 10:27:11 -050090addtask do_write_qemuboot_conf after do_rootfs before do_image
Patrick Williamsc0f7c042017-02-23 20:41:17 -060091
Brad Bishop6e60e8b2018-02-01 10:27:11 -050092def qemuboot_vars(d):
93 build_vars = ['MACHINE', 'TUNE_ARCH', 'DEPLOY_DIR_IMAGE',
94 'KERNEL_IMAGETYPE', 'IMAGE_NAME', 'IMAGE_LINK_NAME',
95 'STAGING_DIR_NATIVE', 'STAGING_BINDIR_NATIVE',
96 'STAGING_DIR_HOST']
97 return build_vars + [k for k in d.keys() if k.startswith('QB_')]
98
99do_write_qemuboot_conf[vardeps] += "${@' '.join(qemuboot_vars(d))}"
100do_write_qemuboot_conf[vardepsexclude] += "TOPDIR"
101python do_write_qemuboot_conf() {
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600102 import configparser
103
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500104 qemuboot = "%s/%s.qemuboot.conf" % (d.getVar('IMGDEPLOYDIR'), d.getVar('IMAGE_NAME'))
105 qemuboot_link = "%s/%s.qemuboot.conf" % (d.getVar('IMGDEPLOYDIR'), d.getVar('IMAGE_LINK_NAME'))
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500106 finalpath = d.getVar("DEPLOY_DIR_IMAGE")
107 topdir = d.getVar('TOPDIR')
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600108 cf = configparser.ConfigParser()
109 cf.add_section('config_bsp')
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500110 for k in sorted(qemuboot_vars(d)):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500111 # qemu-helper-native sysroot is not removed by rm_work and
112 # contains all tools required by runqemu
113 if k == 'STAGING_BINDIR_NATIVE':
114 val = os.path.join(d.getVar('BASE_WORKDIR'), d.getVar('BUILD_SYS'),
115 'qemu-helper-native/1.0-r1/recipe-sysroot-native/usr/bin/')
116 else:
117 val = d.getVar(k)
118 # we only want to write out relative paths so that we can relocate images
119 # and still run them
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500120 if val.startswith(topdir):
121 val = os.path.relpath(val, finalpath)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500122 cf.set('config_bsp', k, '%s' % val)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600123
124 # QB_DEFAULT_KERNEL's value of KERNEL_IMAGETYPE is the name of a symlink
125 # to the kernel file, which hinders relocatability of the qb conf.
126 # Read the link and replace it with the full filename of the target.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500127 kernel_link = os.path.join(d.getVar('DEPLOY_DIR_IMAGE'), d.getVar('QB_DEFAULT_KERNEL'))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600128 kernel = os.path.realpath(kernel_link)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500129 # we only want to write out relative paths so that we can relocate images
130 # and still run them
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500131 kernel = os.path.relpath(kernel, finalpath)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600132 cf.set('config_bsp', 'QB_DEFAULT_KERNEL', kernel)
133
134 bb.utils.mkdirhier(os.path.dirname(qemuboot))
135 with open(qemuboot, 'w') as f:
136 cf.write(f)
137
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500138 if qemuboot_link != qemuboot:
139 if os.path.lexists(qemuboot_link):
140 os.remove(qemuboot_link)
141 os.symlink(os.path.basename(qemuboot), qemuboot_link)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600142}