blob: f60880c2925abf24a18d2fa6af165314dd2699af [file] [log] [blame]
Andrew Geisslerd25ed322020-06-27 00:28:28 -05001SUMMARY = "IGT GPU Tools"
2DESCRIPTION = "IGT GPU Tools is a collection of tools for development and testing of the DRM drivers"
3
4LIC_FILES_CHKSUM = "file://COPYING;md5=67bfee4df38fa6ecbe3a675c552d4c08"
5
6LICENSE = "MIT"
7
8inherit meson
9
10SRCREV = "d16ad07e7f2a028e14d61f570931c87fa5ce404c"
11PV = "1.25+git${SRCPV}"
12
13SRC_URI = "git://gitlab.freedesktop.org/drm/igt-gpu-tools.git;protocol=https"
14
15S = "${WORKDIR}/git"
16
17DEPENDS += "libdrm libpciaccess cairo udev glib-2.0 procps libunwind kmod openssl elfutils alsa-lib json-c bison-native"
18RDEPENDS_${PN} += "bash"
19RDEPENDS_${PN}-tests += "bash"
20
21PACKAGE_BEFORE_PN = "${PN}-benchmarks ${PN}-tests"
22
23EXTRA_OEMESON = "-Ddocs=disabled -Drunner=enabled"
24COMPATIBLE_HOST = "(x86_64.*|i.86.*|arm.*|aarch64).*-linux"
25COMPATIBLE_HOST_libc-musl_class-target = "null"
26SECURITY_LDFLAGS = "${SECURITY_X_LDFLAGS}"
27
28gputools_sysroot_preprocess() {
29 rm -f ${SYSROOT_DESTDIR}${libdir}/pkgconfig/intel-gen4asm.pc
30}
31SYSROOT_PREPROCESS_FUNCS += "gputools_sysroot_preprocess"
32
33do_install_append() {
34 install -d ${D}/usr/share/${BPN}/scripts
35 install ${S}/scripts/run-tests.sh ${D}/usr/share/${BPN}/scripts
36 install -d ${D}/usr/share/${BPN}/runner
37 install -D ${B}/runner/igt_runner ${D}/usr/share/${BPN}/runner
38 install -D ${B}/runner/igt_resume ${D}/usr/share/${BPN}/runner
39}
40
41FILES_${PN}-benchmarks += "${libexecdir}/${BPN}/benchmarks"
42FILES_${PN}-tests += "\
43 ${libexecdir}/${BPN}/*\
44 ${datadir}/${BPN}/1080p-right.png\
45 ${datadir}/${BPN}/1080p-left.png\
46 ${datadir}/${BPN}/pass.png\
47 ${datadir}/${BPN}/test-list.txt"