blob: 60f84f8f9c64ea006ab82abfe52f49b8d7fd32be [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A command line Linux program which mounts and unmounts removable devices"
2HOMEPAGE = "http://ignorantguru.github.io/udevil/"
3
4DEPENDS = "glib-2.0 \
5 glib-2.0-native \
6 intltool-native \
7 udev \
8"
9RDEPENDS_${PN} = "udev bash"
10
11LICENSE = "GPL-3.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
13
14inherit autotools systemd
15
16SRC_URI = "https://github.com/IgnorantGuru/udevil/raw/pkg/${PV}/udevil-${PV}.tar.xz \
17 file://0001-udevil-0.4.3-fix-compile-with-gcc6.patch \
18 file://0002-etc-Makefile.am-Use-systemd_unitdir-instead-of-libdi.patch \
19"
20
21SRC_URI[md5sum] = "dc1c489b603a0500a04dc7e1805ac1d9"
22SRC_URI[sha256sum] = "ce8c51fd4d589cda7be56e75b42188deeb258c66fc911a9b3a70a3945c157739"
23
24PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
25PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
26
27SYSTEMD_SERVICE_${PN} = "devmon@.service"
28SYSTEMD_AUTO_ENABLE = "disable"