blob: a0055b97ee848f76a5791c12a1ae1a8217dc6af7 [file] [log] [blame]
Dung Cao74dbe1e2021-01-12 04:44:23 +00001SUMMARY = "Phosphor OpenBMC SSIF to DBUS"
2DESCRIPTION = "Phosphor OpenBMC SSIF to DBUS."
3PR = "r1"
Benjamin Faird35004f2021-02-03 09:53:33 -08004PV = "1.0+git${SRCPV}"
Dung Cao74dbe1e2021-01-12 04:44:23 +00005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit meson pkgconfig
9inherit systemd
10
11SYSTEMD_SERVICE_${PN} = "ssifbridge.service"
12
13PROVIDES += "virtual/obmc-host-ipmi-hw"
14RPROVIDES_${PN} += "virtual-obmc-host-ipmi-hw"
15RRECOMMENDS_${PN} += "phosphor-ipmi-host"
16
17DEPENDS += "systemd"
18DEPENDS += "phosphor-logging"
19DEPENDS += "sdbusplus"
20DEPENDS += "cli11"
21
22S = "${WORKDIR}/git"
23SRC_URI = "git://github.com/openbmc/ssifbridge.git;protocol=git;branch=master"
Andrew Geissler130419d2021-02-03 09:41:06 +000024SRCREV= "b26a9b6aea6c578fa71274bed14466607b0d8426"
Dung Cao74dbe1e2021-01-12 04:44:23 +000025