blob: da138e358746b62b7a707b04e9d44fbebae3e838 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "GPL-3.0-only"
Andrew Geisslereff27472021-10-29 15:35:00 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
Patrick Williams2a254922023-08-11 09:48:11 -050013 file://autoconf-2.73.patch \
Andrew Geisslereff27472021-10-29 15:35:00 -050014 file://add-with-bisonlocaledir.patch \
15 "
16SRC_URI[sha256sum] = "9bba0214ccf7f1079c5d59210045227bcf619519840ebfa80cd3849cff5a5bf2"
17
18inherit autotools gettext texinfo
19
20# No point in hardcoding path to m4, just use PATH
21CACHED_CONFIGUREVARS = "ac_cv_path_M4=m4"
22
23PACKAGECONFIG ??= "readline ${@ 'textstyle' if d.getVar('USE_NLS') == 'yes' else ''}"
24PACKAGECONFIG:class-native ??= ""
25
26# Make readline and textstyle optional. There are recipie for these, but leave them
27# disabled for the native recipe. This prevents host contamination of the native tool.
28PACKAGECONFIG[readline] = "--with-libreadline-prefix,--without-libreadline-prefix,readline"
29PACKAGECONFIG[textstyle] = "--with-libtextstyle-prefix,--without-libtextstyle-prefix,gettext"
30
31# Include the cached configure variables, configure is really good at finding
32# libreadline, even if we don't want it.
33CACHED_CONFIGUREVARS += "${@bb.utils.contains('PACKAGECONFIG', 'readline', '', ' \
34 ac_cv_header_readline_history_h=no \
35 ac_cv_header_readline_readline_h=no \
36 gl_cv_lib_readline=no', d)} \
37 ${@bb.utils.contains('PACKAGECONFIG', 'textstyle', '', ' \
38 ac_cv_libtextstyle=no', d)}"
39
40# The automatic m4 path detection gets confused, so force the right value
41acpaths = "-I ./m4"
42
43do_compile:prepend() {
44 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
45}
46
47do_install:append:class-native() {
48 create_wrapper ${D}/${bindir}/bison \
49 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
50}
51do_install:append:class-nativesdk() {
52 create_wrapper ${D}/${bindir}/bison \
53 BISON_PKGDATADIR=${datadir}/bison
54}
55BBCLASSEXTEND = "native nativesdk"