blob: 18ce1adf1dddf0ad8b5e4ec8ec5fededf7375bd1 [file] [log] [blame]
Deepak Kodihalli14c47d22017-03-17 03:51:13 -05001SUMMARY = "Open POWER DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the openpower YAML"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-license
9inherit pythonnative
Marri Devender Rao8dd77982017-05-29 01:33:26 -050010inherit phosphor-dbus-yaml
Deepak Kodihalli14c47d22017-03-17 03:51:13 -050011
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "sdbus++-native"
14
Deepak Kodihalli14c47d22017-03-17 03:51:13 -050015SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces"
Andrew Geissler36b3de62018-05-29 19:30:02 -050016SRCREV = "db61501f7a2ad964555b3fb482a2bb4cffcbbb9d"
Deepak Kodihalli14c47d22017-03-17 03:51:13 -050017
18DEPENDS_remove_class-native = "sdbus++-native"
19DEPENDS_remove_class-nativesdk = "sdbus++-native"
20
21PACKAGECONFIG ??= "libopenpower_dbus"
22PACKAGECONFIG[libopenpower_dbus] = " \
23 --enable-libopenpower_dbus, \
24 --disable-libopenpower_dbus, \
25 systemd sdbusplus, \
26 libsystemd sdbusplus \
27 "
28
29PACKAGECONFIG_remove_class-native = "libopenpower_dbus"
30PACKAGECONFIG_remove_class-nativesdk = "libopenpower_dbus"
31
32BBCLASSEXTEND += "native nativesdk"