blob: 4959a3b73f43994b56468725aafbed2047869bad [file] [log] [blame]
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05301SUMMARY = "OpenPOWER Host checkstop monitor application"
2PR = "r1"
3
4inherit obmc-phosphor-systemd
5inherit obmc-phosphor-license
6inherit allarch
7
8DEPENDS += "virtual/obmc-gpio-monitor"
9RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
10
11# For now, monitoring checkstop is the only usecase
12OBMC_HOST_MONITOR_INSTANCES = "checkstop"
13
14# Copies config file having arguments for monitoring host checkstop
15# via GPIO assertion
16SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop"
17
Vishwanatha Subbannaa1f486e2017-07-26 16:41:03 +053018# This package is not supplying the unit file and also this is not a native
19# recipe since state-mgmt needs this package at runtime. Unsetting this below
20# variable will let the build go through
21SYSTEMD_SERVICE_${PN} ?=""
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +053022
Vishwanatha Subbannaa1f486e2017-07-26 16:41:03 +053023# Install the override to set up a Conflicts relation
24SYSTEMD_OVERRIDE_${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
25
Andrew Geissler5c76e0c2018-03-27 13:56:26 -070026STATES = "startmin"
Vishwanatha Subbannaa1f486e2017-07-26 16:41:03 +053027GPIO_MONITOR_TMPL = "phosphor-gpio-monitor@.service"
28GPIO_MONITOR_TGTFMT = "phosphor-gpio-monitor@{1}.service"
29CHECKSTOP_MONITOR_FMT = "../${GPIO_MONITOR_TMPL}:obmc-host-{0}@{2}.target.wants/${GPIO_MONITOR_TGTFMT}"
Vishwanatha Subbannad521ee62017-06-07 21:00:16 +053030SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"