blob: 39beb480cddeb488d490abf5f138e6dba12e7944 [file] [log] [blame]
Joel Stanley88aae3e2018-05-11 15:16:32 +09301SUMMARY = "OpenPower Hostboot Boot settings tool"
2PR = "r1"
3
4inherit obmc-phosphor-license
5inherit obmc-phosphor-systemd
6inherit allarch
7
8SRC_URI = "file://hb_settings"
9SYSTEMD_SERVICE_${PN} += "hostboot-settings.service"
10
11do_fetch[noexec] = "1"
12do_patch[noexec] = "1"
13do_configure[noexec] = "1"
14do_compile[noexec] = "1"
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m 0755 ${WORKDIR}/hb_settings ${D}${bindir}
19}