blob: e851ee1b32e9079b268a5d9fcb1e02316d340b71 [file] [log] [blame]
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +05301SUMMARY = "OpenPower OCC Control with MRW generated sensor IDs"
2PR = "r1"
3
4inherit native
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +05305inherit obmc-phosphor-license
6inherit openpower-occ-control
Matt Spinler0a8ea632017-12-14 13:31:55 -06007inherit mrw-xml
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +05308
9PROVIDES += "virtual/openpower-occ-control-config-native"
10DEPENDS += "mrw-native mrw-perl-tools-native"
11
12# Generate a YAML files based on MRW input
13do_install_append() {
14 install -d ${YAML_DEST}/
15 ${STAGING_BINDIR_NATIVE}/perl-native/perl \
16 ${STAGING_BINDIR_NATIVE}/gen_occ_map.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060017 -i ${mrw_datadir}/${MRW_XML} \
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +053018 -o ${YAML_DEST}/occ_sensor.yaml
19}