blob: a064cf1b0e1cd9e7f6a89f9d4b2619a2d0484898 [file] [log] [blame]
Matthew Barthacd9fe42017-02-24 13:14:43 -06001SUMMARY = "Phosphor Fan Presence"
2DESCRIPTION = "Phosphor fan presence provides a set of fan presence \
3daemons to monitor fan presence changes by different methods of \
4presence detection."
Matthew Barthacd9fe42017-02-24 13:14:43 -06005PR = "r1"
Matt Spinlerf7d548b2017-03-21 15:02:13 -05006
7require ${PN}.inc
Matthew Barthacd9fe42017-02-24 13:14:43 -06008
9inherit autotools pkgconfig pythonnative
10inherit obmc-phosphor-systemd
Matt Spinlerf7d548b2017-03-21 15:02:13 -050011inherit phosphor-fan-presence
Matthew Barthacd9fe42017-02-24 13:14:43 -060012
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "python-pyyaml-native"
Matt Spinlerf7d548b2017-03-21 15:02:13 -050015DEPENDS += "python-mako-native"
Matthew Barthacd9fe42017-02-24 13:14:43 -060016DEPENDS += "sdbusplus"
17DEPENDS += "phosphor-logging"
Matt Spinlerf7d548b2017-03-21 15:02:13 -050018DEPENDS += "virtual/phosphor-fan-presence-config"
Brad Bishopa0fc7ea2017-04-03 10:44:23 -040019DEPENDS += "libevdev"
Matthew Barthacd9fe42017-02-24 13:14:43 -060020
21FAN_PRESENCE_PACKAGES = " \
22 ${PN}-tach \
23"
24PACKAGES_remove = "${PN}"
Brad Bishopd4c38482017-04-11 22:12:56 -040025PACKAGES += "${FAN_PRESENCE_PACKAGES} phosphor-chassis-cooling-type"
26
27# Remove when this package has content
28ALLOW_EMPTY_phosphor-chassis-cooling-type = "1"
29
Matthew Barthacd9fe42017-02-24 13:14:43 -060030SYSTEMD_PACKAGES = "${FAN_PRESENCE_PACKAGES}"
Brad Bishopd4c38482017-04-11 22:12:56 -040031RDEPENDS_${PN}-dev = "${FAN_PRESENCE_PACKAGES} phosphor-chassis-cooling-type"
Matthew Barthacd9fe42017-02-24 13:14:43 -060032
Brad Bishopa072ab22017-04-11 21:51:26 -040033RDEPENDS_${PN}-tach += "sdbusplus"
34
Brad Bishopd4c38482017-04-11 22:12:56 -040035RDEPENDS_phosphor-chassis-cooling-type += "libevdev"
36
Matthew Barthacd9fe42017-02-24 13:14:43 -060037# Needed to install into the obmc-chassis-start target
38TMPL = "phosphor-fan-presence-tach@.service"
39INSTFMT = "phosphor-fan-presence-tach@{0}.service"
40TGTFMT = "obmc-chassis-start@{0}.target"
41FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
42
43FILES_${PN}-tach = "${sbindir}/phosphor-fan-presence-tach"
44SYSTEMD_SERVICE_${PN}-tach += "${TMPL}"
45SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
46
Matthew Barthacd9fe42017-02-24 13:14:43 -060047S = "${WORKDIR}/git"
Matt Spinlerf7d548b2017-03-21 15:02:13 -050048
49EXTRA_OECONF = \
50 "FAN_DETECT_YAML_FILE=${STAGING_DIR_NATIVE}${presence_datadir}/config.yaml"