blob: 305c2b7da09053d641cdad38e8e2a28baf8460f4 [file] [log] [blame]
Brad Bishopd4d38762016-06-07 16:25:54 -04001SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
7SRCREV = "d0847e6b3eda43d4d2b4f9928a549c3c2d52865f"
8UBRANCH = "v2016.05-ast2500"
9SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https"
10
11PV = "v2016.05+git${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15INSANE_SKIP_${PN} = "already-stripped"
16EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
17EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
18
19inherit uboot-config
20
21do_compile () {
22 oe_runmake ${UBOOT_MACHINE}
23 oe_runmake env
24}
25
26do_install () {
27 install -d ${D}${base_sbindir}
28 install -d ${D}${sysconfdir}
29 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
30 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
31 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
32}
33
34do_install_class-cross () {
35 install -d ${D}${bindir_cross}
36 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
37 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
38}
39
40SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
41uboot_fw_utils_cross() {
42 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
43}
44
45PACKAGE_ARCH = "${MACHINE_ARCH}"
46BBCLASSEXTEND = "cross"