blob: f2434adb522643acf994e55be19d4155be89b103 [file] [log] [blame]
Brad Bishop81d8c1d2015-10-08 15:15:52 -04001require recipes-bsp/u-boot/u-boot.inc
2
3# To build u-boot for your machine, provide the following lines in your machine
4# config, replacing the assignments as appropriate for your machine.
5# UBOOT_MACHINE = "omap3_beagle_config"
6# UBOOT_ENTRYPOINT = "0x80008000"
7# UBOOT_LOADADDRESS = "0x80008000"
8
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
11 file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
12
Brad Bishop81d8c1d2015-10-08 15:15:52 -040013# We use the revision in order to avoid having to fetch it from the repo during parse
Joel Stanleyff22c4f2016-04-03 23:15:36 +093014SRCREV = "44f1262bdf39ad93032d39f17a298165372be82e"
Brad Bishop81d8c1d2015-10-08 15:15:52 -040015
16PV = "v2013.07+git${SRCPV}"
17
Chris Austen4f1ef522016-01-19 14:45:55 -060018UBRANCH = "v2013.07-aspeed-openbmc"
19SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https"
Brad Bishop81d8c1d2015-10-08 15:15:52 -040020
21S = "${WORKDIR}/git"
22
23PACKAGE_ARCH = "${MACHINE_ARCH}"