blob: 7d352f4218d15a7949f0baff5bc4ade29e7e31e3 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Simple DirectMedia Layer truetype font library"
2SECTION = "libs"
3DEPENDS = "libsdl2 freetype virtual/egl"
4LICENSE = "Zlib"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05005LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a41cbf59bdea749fe34c1af6d3615f68"
Patrick Williams92b42cb2022-09-03 06:53:57 -05006
7SRC_URI = " \
8 git://github.com/libsdl-org/SDL_ttf.git;branch=release-2.20.x;protocol=https \
9 git://github.com/libsdl-org/freetype.git;branch=VER-2-12-1-SDL;destsuffix=git/external/freetype;name=freetype;protocol=https \
10 git://github.com/libsdl-org/harfbuzz.git;branch=2.9.1-SDL;destsuffix=git/external/harfbuzz;name=harfbuzz;protocol=https \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050011 file://0001-freetype-Fix-function-signatures-to-match-without-ca.patch;patchdir=external/harfbuzz \
Patrick Williams92b42cb2022-09-03 06:53:57 -050012 file://automake_foreign.patch \
13"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050014SRCREV = "89d1692fd8fe91a679bb943d377bfbd709b52c23"
Patrick Williams92b42cb2022-09-03 06:53:57 -050015SRCREV_freetype = "6fc77cee03e078e97afcee0c0e06a2d3274b9a29"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050016SRCREV_harfbuzz = "43931e3e596c04044861770b831c8f9452e2d3b0"
Patrick Williams92b42cb2022-09-03 06:53:57 -050017
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig features_check
21
22# links to libGL.so
23REQUIRED_DISTRO_FEATURES += "opengl"
24
25do_configure:prepend() {
26 # Removing these files fixes a libtool version mismatch.
27 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
28
29 for i in ${MACROS}; do
30 rm -f ${S}/acinclude/$i
31 done
32}
33ASNEEDED = ""